arm64: bpf: Only mitigate cBPF programs loaded by unprivileged users
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: arm64: bpf: Only mitigate cBPF programs loaded by unprivileged users Support for eBPF programs loaded by unprivileged users is typically disabled. This means only cBPF programs need to be mitigated for BHB. In addition, only mitigate cBPF programs that were loaded by an unprivileged user. Privileged users can also load the same program via eBPF, making the mitigation pointless.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.7 and later | 5.10.239, 5.15.186, 6.1.139, 6.6.91, 6.12.29, 6.14.7, 6.15 | Patch available | CNA |
- Linux VendorLinux Affected 3.7 and later Fixed in 5.10.239, 5.15.186, 6.1.139, 6.6.91, 6.12.29, 6.14.7, 6.15 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 5.10.239; 5.11 to before 5.15.186; 5.16 to before 6.1.139; 6.2 to before 6.6.91; 6.7 to before 6.12.29; 6.13 to before 6.14.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc1:*:*:*:*:*:* | 6.15 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc2:*:*:*:*:*:* | 6.15 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc3:*:*:*:*:*:* | 6.15 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc4:*:*:*:*:*:* | 6.15 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc5:*:*:*:*:*:* | 6.15 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc6:*:*:*:*:*:* | 6.15 rc6 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 5.10.239; 5.11 to before 5.15.186; 5.16 to before 6.1.139; 6.2 to before 6.6.91; 6.7 to before 6.12.29; 6.13 to before 6.14.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc1:*:*:*:*:*:* Versions 6.15 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc2:*:*:*:*:*:* Versions 6.15 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc3:*:*:*:*:*:* Versions 6.15 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc4:*:*:*:*:*:* Versions 6.15 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc5:*:*:*:*:*:* Versions 6.15 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc6:*:*:*:*:*:* Versions 6.15 rc6 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.239, 5.15.186, 6.1.139, 6.6.91, 6.12.29, 6.14.7, 6.15
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Not affected: 2 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2025-37963
- 2026-10-03 Alias added: GHSA-v8x8-x32m-fh4m
- 2026-11-05 CISA SSVC decision points changed
References
Patch 7
- https://git.kernel.org/stable/c/038866e01ea5e5a3d948898ac216e531e7848669
- https://git.kernel.org/stable/c/df53d418709205450a02bb4d71cbfb4ff86f2c1e
- https://git.kernel.org/stable/c/6e52d043f7dbf1839a24a3fab2b12b0d3839de7a
- https://git.kernel.org/stable/c/80251f62028f1ab2e09be5ca3123f84e8b00389a
- https://git.kernel.org/stable/c/e5f5100f1c64ac6c72671b2cf6b46542fce93706
- https://git.kernel.org/stable/c/477481c4348268136227348984b6699d6370b685
- https://git.kernel.org/stable/c/f300769ead032513a68e4a02e806393402e626f8
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-37963 · CVE Program
- CVE-2025-37963 · NVD
- FIRST EPSS
- GHSA-v8x8-x32m-fh4m · GitHub Advisory Database · CC BY 4.0
- CVE-2025-37963 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences