iio: imu: st_lsm6dsx: fix possible lockup in st_lsm6dsx_read_fifo
Priority LOW 24CWE-667Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-667 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: iio: imu: st_lsm6dsx: fix possible lockup in st_lsm6dsx_read_fifo Prevent st_lsm6dsx_read_fifo from falling in an infinite loop in case pattern_len is equal to zero and the device FIFO is not empty.
Why it matters now
EPSS 0.00181 7th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.4.294, 5.10.238, 5.15.183 +5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.11 and later | 5.4.294, 5.10.238, 5.15.183, 6.1.139, 6.6.91, 6.12.29, 6.14.7, 6.15 | Patch available | CNA |
- Linux VendorLinux Affected 4.11 and later Fixed in 5.4.294, 5.10.238, 5.15.183, 6.1.139, 6.6.91, 6.12.29, 6.14.7, 6.15 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.11 to before 5.4.294; 5.5 to before 5.10.238; 5.11 to before 5.15.183; 5.16 to before 6.1.139; 6.2 to before 6.6.91; 6.7 to before 6.12.29; 6.13 to before 6.14.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc1:*:*:*:*:*:* | 6.15 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc2:*:*:*:*:*:* | 6.15 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc3:*:*:*:*:*:* | 6.15 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc4:*:*:*:*:*:* | 6.15 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc5:*:*:*:*:*:* | 6.15 rc5 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.11 to before 5.4.294; 5.5 to before 5.10.238; 5.11 to before 5.15.183; 5.16 to before 6.1.139; 6.2 to before 6.6.91; 6.7 to before 6.12.29; 6.13 to before 6.14.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc1:*:*:*:*:*:* Versions 6.15 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc2:*:*:*:*:*:* Versions 6.15 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc3:*:*:*:*:*:* Versions 6.15 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc4:*:*:*:*:*:* Versions 6.15 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc5:*:*:*:*:*:* Versions 6.15 rc5 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.294, 5.10.238, 5.15.183, 6.1.139, 6.6.91, 6.12.29, 6.14.7, 6.15
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-37970
- 2026-10-03 Alias added: GHSA-7xj4-qj2w-mpf9
References
Patch 8
- https://git.kernel.org/stable/c/f06a1a1954527cc4ed086d926c81ff236b2adde9
- https://git.kernel.org/stable/c/84e39f628a3a3333add99076e4d6c8b42b12d3a0
- https://git.kernel.org/stable/c/f3cf233c946531a92fe651ff2bd15ebbe60630a7
- https://git.kernel.org/stable/c/6c4a5000618a8c44200d455c92e2f2a4db264717
- https://git.kernel.org/stable/c/da33c4167b9cc1266a97215114cb74679f881d0c
- https://git.kernel.org/stable/c/a1cad8a3bca41dead9980615d35efc7bff1fd534
- https://git.kernel.org/stable/c/3bb6c02d6fe8347ce1785016d135ff539c20043c
- https://git.kernel.org/stable/c/159ca7f18129834b6f4c7eae67de48e96c752fc9
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-37970 · CVE Program
- CVE-2025-37970 · NVD
- FIRST EPSS
- GHSA-7xj4-qj2w-mpf9 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-37970 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences