can: bcm: add missing rcu read protection for procfs content
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: can: bcm: add missing rcu read protection for procfs content When the procfs content is generated for a bcm_op which is in the process to be removed the procfs output might show unreliable data (UAF). As the removal of bcm_op's is already implemented with rcu handling this patch adds the missing rcu_read_lock() and makes sure the list entries are properly removed under rcu protection.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.4.205 to before 5.4.294; 5.10.130 to before 5.10.238; 5.15.54 to before 5.15.185; 4.19.252 to before 4.20; 5.18.11 to before 5.19 | 5.4.294, 5.10.238, 5.15.185, 4.20, 5.19 | Patch available | CNA |
| Linux | Linux | 5.19 and later | 5.4.294, 5.10.238, 5.15.185, 6.1.141, 6.6.93, 6.12.31, 6.14.9, 6.15 | Patch available | CNA |
- Linux VendorLinux Affected 5.4.205 to before 5.4.294; 5.10.130 to before 5.10.238; 5.15.54 to before 5.15.185; 4.19.252 to before 4.20; 5.18.11 to before 5.19 Fixed in 5.4.294, 5.10.238, 5.15.185, 4.20, 5.19 Patch available CNA
- Linux VendorLinux Affected 5.19 and later Fixed in 5.4.294, 5.10.238, 5.15.185, 6.1.141, 6.6.93, 6.12.31, 6.14.9, 6.15 Patch available CNA
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.19.252 to before 4.20; 5.4.205 to before 5.4.294; 5.10.130 to before 5.10.238; 5.15.54 to before 5.15.185; 5.18.11 to before 5.19; 5.19.1 to before 6.1.141; 6.2 to before 6.6.93; 6.7 to before 6.12.31; 6.13 to before 6.14.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:-:*:*:*:*:*:* | 5.19 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc6:*:*:*:*:*:* | 5.19 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc7:*:*:*:*:*:* | 5.19 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc8:*:*:*:*:*:* | 5.19 rc8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc1:*:*:*:*:*:* | 6.15 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc2:*:*:*:*:*:* | 6.15 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc3:*:*:*:*:*:* | 6.15 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc4:*:*:*:*:*:* | 6.15 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc5:*:*:*:*:*:* | 6.15 rc5 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.19.252 to before 4.20; 5.4.205 to before 5.4.294; 5.10.130 to before 5.10.238; 5.15.54 to before 5.15.185; 5.18.11 to before 5.19; 5.19.1 to before 6.1.141; 6.2 to before 6.6.93; 6.7 to before 6.12.31; 6.13 to before 6.14.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:-:*:*:*:*:*:* Versions 5.19 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc6:*:*:*:*:*:* Versions 5.19 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc7:*:*:*:*:*:* Versions 5.19 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc8:*:*:*:*:*:* Versions 5.19 rc8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc1:*:*:*:*:*:* Versions 6.15 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc2:*:*:*:*:*:* Versions 6.15 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc3:*:*:*:*:*:* Versions 6.15 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc4:*:*:*:*:*:* Versions 6.15 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc5:*:*:*:*:*:* Versions 6.15 rc5 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.294, 5.10.238, 5.15.185, 4.20, 5.19
- Fix · CNA Linux (Linux) Fixed in 5.4.294, 5.10.238, 5.15.185, 6.1.141, 6.6.93, 6.12.31, 6.14.9, 6.15
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix planned: Out of support scope |
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2025-38003
- 2026-10-03 Alias added: GHSA-w495-f5mg-799h
References
Patch 8
- https://git.kernel.org/stable/c/19f553a1ddf260da6570ed8f8d91a8c87f49b63a
- https://git.kernel.org/stable/c/659701c0b954ccdb4a916a4ad59bbc16e726d42c
- https://git.kernel.org/stable/c/0622846db728a5332b917c797c733e202c4620ae
- https://git.kernel.org/stable/c/6d7d458c41b98a5c1670cbd36f2923c37de51cf5
- https://git.kernel.org/stable/c/1f912f8484e9c4396378c39460bbea0af681f319
- https://git.kernel.org/stable/c/63567ecd99a24495208dc860d50fb17440043006
- https://git.kernel.org/stable/c/7c9db92d5f0eadca30884af75c53d601edc512ee
- https://git.kernel.org/stable/c/dac5e6249159ac255dad9781793dbe5908ac9ddb
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-38003 · CVE Program
- CVE-2025-38003 · NVD
- FIRST EPSS
- GHSA-w495-f5mg-799h · GitHub Advisory Database · CC BY 4.0
- CVE-2025-38003 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences