platform/x86: dell-wmi-sysman: Avoid buffer overflow in current_password_store()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-787 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: platform/x86: dell-wmi-sysman: Avoid buffer overflow in current_password_store() If the 'buf' array received from the user contains an empty string, the 'length' variable will be zero. Accessing the 'buf' array element with index 'length - 1' will result in a buffer overflow. Add a check for an empty string. Found by Linux Verification Center (linuxtesting.org) with SVACE.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.11 and later | 5.15.185, 6.1.141, 6.6.93, 6.12.31, 6.14.9, 6.15 | Patch available | CNA |
- Linux VendorLinux Affected 5.11 and later Fixed in 5.15.185, 6.1.141, 6.6.93, 6.12.31, 6.14.9, 6.15 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.11 to before 5.15.185; 5.16 to before 6.1.141; 6.2 to before 6.6.93; 6.7 to before 6.12.31; 6.13 to before 6.14.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc1:*:*:*:*:*:* | 6.15 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc2:*:*:*:*:*:* | 6.15 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc3:*:*:*:*:*:* | 6.15 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc4:*:*:*:*:*:* | 6.15 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc5:*:*:*:*:*:* | 6.15 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc6:*:*:*:*:*:* | 6.15 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc7:*:*:*:*:*:* | 6.15 rc7 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.11 to before 5.15.185; 5.16 to before 6.1.141; 6.2 to before 6.6.93; 6.7 to before 6.12.31; 6.13 to before 6.14.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc1:*:*:*:*:*:* Versions 6.15 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc2:*:*:*:*:*:* Versions 6.15 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc3:*:*:*:*:*:* Versions 6.15 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc4:*:*:*:*:*:* Versions 6.15 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc5:*:*:*:*:*:* Versions 6.15 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc6:*:*:*:*:*:* Versions 6.15 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc7:*:*:*:*:*:* Versions 6.15 rc7 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.15.185, 6.1.141, 6.6.93, 6.12.31, 6.14.9, 6.15
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix planned: Out of support scope |
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2025-38077
- 2026-10-03 Alias added: GHSA-6xx4-fvpc-r9qf
References
Patch 6
- https://git.kernel.org/stable/c/fb7cde625872709b8cedad9b241e0ec3d82fa7d3
- https://git.kernel.org/stable/c/60bd13f8c4b3de2c910ae1cdbef85b9bbc9685f5
- https://git.kernel.org/stable/c/f86465626917df3b8bdd2756ec0cc9d179c5af0f
- https://git.kernel.org/stable/c/8594a123cfa23d708582dc6fb36da34479ef8a5b
- https://git.kernel.org/stable/c/97066373ffd55bd9af0b512ff3dd1f647620a3dc
- https://git.kernel.org/stable/c/4e89a4077490f52cde652d17e32519b666abf3a6
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-38077 · CVE Program
- CVE-2025-38077 · NVD
- FIRST EPSS
- GHSA-6xx4-fvpc-r9qf · GitHub Advisory Database · CC BY 4.0
- CVE-2025-38077 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences