Read the docs
TI-2025-25444 Aliases CVE-2025-38103GHSA-8xp3-mcw7-w7cp

HID: usbhid: Eliminate recurrent out-of-bounds bug in usbhid_parse()

Priority LOW 31CWE-125Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · High
Fix status
Partial Red Hat: 5 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.

Summary

In the Linux kernel, the following vulnerability has been resolved: HID: usbhid: Eliminate recurrent out-of-bounds bug in usbhid_parse() Update struct hid_descriptor to better reflect the mandatory and optional parts of the HID Descriptor as per USB HID 1.11 specification. Note: the kernel currently does not parse any optional HID class descriptors, only the mandatory report descriptor. Update all references to member element desc[0] to rpt_desc. Add test to verify bLength and bNumDescriptors values are valid. Replace the for loop with direct access to the mandatory HID class descriptor member for the report descriptor. This eliminates the possibility of getting an out-of-bounds fault. Add a warning message if the HID descriptor contains any unsupported optional HID class descriptors.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00229 13th percentileScored 2026-11-07
Fix Partial Linux (Linux): 3.3, 3.17, 3.19 +12Red Hat: 5 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux3.2.95 to before 3.3; 3.16.50 to before 3.17; 3.18.76 to before 3.19; 4.1.46 to before 4.2; 4.4.93 to before 4.5; 4.9.57 to before 4.10; 4.13.8 to before 4.143.3, 3.17, 3.19, 4.2, 4.5, 4.10, 4.14Patch availableCNA
LinuxLinux4.14 and later5.4.295, 5.10.239, 5.15.186, 6.1.142, 6.6.94, 6.12.34, 6.15.3, 6.16Patch availableCNA
  • Linux VendorLinux Affected 3.2.95 to before 3.3; 3.16.50 to before 3.17; 3.18.76 to before 3.19; 4.1.46 to before 4.2; 4.4.93 to before 4.5; 4.9.57 to before 4.10; 4.13.8 to before 4.14 Fixed in 3.3, 3.17, 3.19, 4.2, 4.5, 4.10, 4.14 Patch available CNA
  • Linux VendorLinux Affected 4.14 and later Fixed in 5.4.295, 5.10.239, 5.15.186, 6.1.142, 6.6.94, 6.12.34, 6.15.3, 6.16 Patch available CNA

CPE configurations NVD · 7

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*3.2.95 to before 3.3; 3.16.50 to before 3.17; 3.18.76 to before 3.19; 4.1.46 to before 4.2; 4.4.93 to before 4.5; 4.9.57 to before 4.10; 4.13.8 to before 4.14; 4.14.1 to before 5.4.295; 5.5 to before 5.10.239; 5.11 to before 5.15.186; 5.16 to before 6.1.142; 6.2 to before 6.6.94; 6.7 to before 6.12.34; 6.13 to before 6.15.3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:4.14:-:*:*:*:*:*:*4.14VulnerableLinux
cpe:2.3:o:linux:linux_kernel:4.14:rc5:*:*:*:*:*:*4.14 rc5VulnerableLinux
cpe:2.3:o:linux:linux_kernel:4.14:rc6:*:*:*:*:*:*4.14 rc6VulnerableLinux
cpe:2.3:o:linux:linux_kernel:4.14:rc7:*:*:*:*:*:*4.14 rc7VulnerableLinux
cpe:2.3:o:linux:linux_kernel:4.14:rc8:*:*:*:*:*:*4.14 rc8VulnerableLinux
cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*11.0VulnerableDebian
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 3.2.95 to before 3.3; 3.16.50 to before 3.17; 3.18.76 to before 3.19; 4.1.46 to before 4.2; 4.4.93 to before 4.5; 4.9.57 to before 4.10; 4.13.8 to before 4.14; 4.14.1 to before 5.4.295; 5.5 to before 5.10.239; 5.11 to before 5.15.186; 5.16 to before 6.1.142; 6.2 to before 6.6.94; 6.7 to before 6.12.34; 6.13 to before 6.15.3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:4.14:-:*:*:*:*:*:* Versions 4.14 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:4.14:rc5:*:*:*:*:*:* Versions 4.14 rc5 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:4.14:rc6:*:*:*:*:*:* Versions 4.14 rc6 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:4.14:rc7:*:*:*:*:*:* Versions 4.14 rc7 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:4.14:rc8:*:*:*:*:*:* Versions 4.14 rc8 Vulnerable ·Linux
  • cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian

Remediation

  • Fix · CNA Linux (Linux) Fixed in 3.3, 3.17, 3.19, 4.2, 4.5, 4.10, 4.14
  • Fix · CNA Linux (Linux) Fixed in 5.4.295, 5.10.239, 5.15.186, 6.1.142, 6.6.94, 6.12.34, 6.15.3, 6.16

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 10AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 7AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 8AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 9AffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-38103
  2. 2026-10-03 Alias added: GHSA-8xp3-mcw7-w7cp
  3. 2026-11-05 CISA SSVC decision points changed

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources