rose: fix dangling neighbour pointers in rose_rt_device_down()
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-416 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: rose: fix dangling neighbour pointers in rose_rt_device_down() There are two bugs in rose_rt_device_down() that can cause use-after-free: 1. The loop bound `t->count` is modified within the loop, which can cause the loop to terminate early and miss some entries. 2. When removing an entry from the neighbour array, the subsequent entries are moved up to fill the gap, but the loop index `i` is still incremented, causing the next entry to be skipped. For example, if a node has three neighbours (A, A, B) with count=3 and A is being removed, the second A is not checked. i=0: (A, A, B) -> (A, B) with count=2 ^ checked i=1: (A, B) -> (A, B) with count=2 ^ checked (B, not A!) i=2: (doesn't occur because i < count is false) This leaves the second A in the array with count=2, but the rose_neigh structure has been freed. Code that accesses these entries assumes that the first `count` entries are valid pointers, causing a use-after-free when it accesses the dangling pointer. Fix both issues by iterating over the array in reverse order with a fixed loop bound. This ensures that all entries are examined and that the removal of an entry doesn't affect subsequent iterations.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.12 and later | 5.4.296, 5.10.240, 5.15.187, 6.1.144, 6.6.97, 6.12.37, 6.15.6, 6.16 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.12 and later Fixed in 5.4.296, 5.10.240, 5.15.187, 6.1.144, 6.6.97, 6.12.37, 6.15.6, 6.16 Patch available CNA
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.13 to before 5.4.296; 5.5 to before 5.10.240; 5.11 to before 5.15.187; 5.16 to before 6.1.144; 6.2 to before 6.6.97; 6.7 to before 6.12.37; 6.13 to before 6.15.6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.12:-:*:*:*:*:*:* | 2.6.12 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.12:rc2:*:*:*:*:*:* | 2.6.12 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.12:rc3:*:*:*:*:*:* | 2.6.12 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.12:rc4:*:*:*:*:*:* | 2.6.12 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.12:rc5:*:*:*:*:*:* | 2.6.12 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.16:rc1:*:*:*:*:*:* | 6.16 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.16:rc2:*:*:*:*:*:* | 6.16 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.16:rc3:*:*:*:*:*:* | 6.16 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.16:rc4:*:*:*:*:*:* | 6.16 rc4 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.13 to before 5.4.296; 5.5 to before 5.10.240; 5.11 to before 5.15.187; 5.16 to before 6.1.144; 6.2 to before 6.6.97; 6.7 to before 6.12.37; 6.13 to before 6.15.6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.12:-:*:*:*:*:*:* Versions 2.6.12 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.12:rc2:*:*:*:*:*:* Versions 2.6.12 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.12:rc3:*:*:*:*:*:* Versions 2.6.12 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.12:rc4:*:*:*:*:*:* Versions 2.6.12 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.12:rc5:*:*:*:*:*:* Versions 2.6.12 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.16:rc1:*:*:*:*:*:* Versions 6.16 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.16:rc2:*:*:*:*:*:* Versions 6.16 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.16:rc3:*:*:*:*:*:* Versions 6.16 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.16:rc4:*:*:*:*:*:* Versions 6.16 rc4 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.296, 5.10.240, 5.15.187, 6.1.144, 6.6.97, 6.12.37, 6.15.6, 6.16
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-38377
- 2026-10-03 Alias added: GHSA-2v78-h87m-hpx9
- 2026-11-07 Affected versions changed · Red Hat
References
Patch 8
- https://git.kernel.org/stable/c/94e0918e39039c47ddceb609500817f7266be756
- https://git.kernel.org/stable/c/fe62a35fb1f77f494ed534fc69a9043dc5a30ce1
- https://git.kernel.org/stable/c/2b952dbb32fef835756f07ff0cd77efbb836dfea
- https://git.kernel.org/stable/c/b6b232e16e08c6dc120672b4753392df0d28c1b4
- https://git.kernel.org/stable/c/7a1841c9609377e989ec41c16551309ce79c39e4
- https://git.kernel.org/stable/c/446ac00b86be1670838e513b643933d78837d8db
- https://git.kernel.org/stable/c/2c6c82ee074bfcfd1bc978ec45bfea37703d840a
- https://git.kernel.org/stable/c/34a500caf48c47d5171f4aa1f237da39b07c6157
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-38377 · CVE Program
- CVE-2025-38377 · NVD
- FIRST EPSS
- GHSA-2v78-h87m-hpx9 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-38377 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences