wifi: ath6kl: remove WARN on bad firmware input
Priority LOW 24Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: wifi: ath6kl: remove WARN on bad firmware input If the firmware gives bad input, that's nothing to do with the driver's stack at this point etc., so the WARN_ON() doesn't add any value. Additionally, this is one of the top syzbot reports now. Just print a message, and as an added bonus, print the sizes too.
Why it matters now
EPSS 0.00208 11th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.4.296, 5.10.240, 5.15.187 +5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.2 and later | 5.4.296, 5.10.240, 5.15.187, 6.1.144, 6.6.97, 6.12.37, 6.15.6, 6.16 | Patch available | CNA |
- Linux VendorLinux Affected 3.2 and later Fixed in 5.4.296, 5.10.240, 5.15.187, 6.1.144, 6.6.97, 6.12.37, 6.15.6, 6.16 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 5.4.296; 5.5 to before 5.10.240; 5.11 to before 5.15.187; 5.16 to before 6.1.144; 6.2 to before 6.6.97; 6.7 to before 6.12.37; 6.13 to before 6.15.6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.16:rc1:*:*:*:*:*:* | 6.16 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.16:rc2:*:*:*:*:*:* | 6.16 rc2 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 5.4.296; 5.5 to before 5.10.240; 5.11 to before 5.15.187; 5.16 to before 6.1.144; 6.2 to before 6.6.97; 6.7 to before 6.12.37; 6.13 to before 6.15.6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.16:rc1:*:*:*:*:*:* Versions 6.16 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.16:rc2:*:*:*:*:*:* Versions 6.16 rc2 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.296, 5.10.240, 5.15.187, 6.1.144, 6.6.97, 6.12.37, 6.15.6, 6.16
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-38406
- 2026-10-03 Alias added: GHSA-3mgj-ppp2-8gvj
References
Patch 8
- https://git.kernel.org/stable/c/7a2afdc5af3b82b601f6a2f0d1c90d5f0bc27aeb
- https://git.kernel.org/stable/c/e6c49f0b203a987c306676d241066451b74db1a5
- https://git.kernel.org/stable/c/46b47d4b06fa7f234d93f0f8ac43798feafcff89
- https://git.kernel.org/stable/c/89bd133529a4d2d68287128b357e49adc00ec690
- https://git.kernel.org/stable/c/347827bd0c5680dac2dd59674616840c4d5154f1
- https://git.kernel.org/stable/c/327997afbb5e62532c28c1861ab5534c01969c9a
- https://git.kernel.org/stable/c/27d07deea35ae67f2e75913242e25bdb7e1114e5
- https://git.kernel.org/stable/c/e7417421d89358da071fd2930f91e67c7128fbff
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-38406 · CVE Program
- CVE-2025-38406 · NVD
- FIRST EPSS
- GHSA-3mgj-ppp2-8gvj · GitHub Advisory Database · CC BY 4.0
- CVE-2025-38406 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences