comedi: pcl812: Fix bit shift out of bounds
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: comedi: pcl812: Fix bit shift out of bounds When checking for a supported IRQ number, the following test is used: if ((1 << it->options[1]) & board->irq_bits) { However, `it->options[i]` is an unchecked `int` value from userspace, so the shift amount could be negative or out of bounds. Fix the test by requiring `it->options[1]` to be within bounds before proceeding with the original test. Valid `it->options[1]` values that select the IRQ will be in the range [1,15]. The value 0 explicitly disables the use of interrupts.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.30 and later | 5.4.297, 5.10.241, 5.15.190, 6.1.147, 6.6.100, 6.12.40, 6.15.8, 6.16 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.30 and later Fixed in 5.4.297, 5.10.241, 5.15.190, 6.1.147, 6.6.100, 6.12.40, 6.15.8, 6.16 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.30 to before 5.4.297; 5.5 to before 5.10.241; 5.11 to before 5.15.190; 5.16 to before 6.1.147; 6.2 to before 6.6.100; 6.7 to before 6.12.40; 6.13 to before 6.15.8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.16:rc1:*:*:*:*:*:* | 6.16 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.16:rc2:*:*:*:*:*:* | 6.16 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.16:rc3:*:*:*:*:*:* | 6.16 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.16:rc4:*:*:*:*:*:* | 6.16 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.16:rc5:*:*:*:*:*:* | 6.16 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.16:rc6:*:*:*:*:*:* | 6.16 rc6 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.30 to before 5.4.297; 5.5 to before 5.10.241; 5.11 to before 5.15.190; 5.16 to before 6.1.147; 6.2 to before 6.6.100; 6.7 to before 6.12.40; 6.13 to before 6.15.8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.16:rc1:*:*:*:*:*:* Versions 6.16 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.16:rc2:*:*:*:*:*:* Versions 6.16 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.16:rc3:*:*:*:*:*:* Versions 6.16 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.16:rc4:*:*:*:*:*:* Versions 6.16 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.16:rc5:*:*:*:*:*:* Versions 6.16 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.16:rc6:*:*:*:*:*:* Versions 6.16 rc6 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.297, 5.10.241, 5.15.190, 6.1.147, 6.6.100, 6.12.40, 6.15.8, 6.16
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-38530
- 2026-10-03 Alias added: GHSA-j2mv-rj6m-hq85
References
Patch 8
- https://git.kernel.org/stable/c/374d9b3eb4b08407997ef1fce96119d31e0c0bc4
- https://git.kernel.org/stable/c/0489c30d080f07cc7f09d04de723d8c2ccdb61ef
- https://git.kernel.org/stable/c/29ef03e5b84431171d6b77b822985b54bc44b793
- https://git.kernel.org/stable/c/5bfa301e1e59a9b1a7b62a800b54852337c97416
- https://git.kernel.org/stable/c/7e470d8efd10725b189ca8951973a8425932398a
- https://git.kernel.org/stable/c/a27e27eee313fe1c450b6af1e80e64412546cab4
- https://git.kernel.org/stable/c/16c173abee315953fd17a279352fec4a1faee862
- https://git.kernel.org/stable/c/b14b076ce593f72585412fc7fd3747e03a5e3632
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-38530 · CVE Program
- CVE-2025-38530 · NVD
- FIRST EPSS
- GHSA-j2mv-rj6m-hq85 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-38530 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences