loop: Avoid updating block size under exclusive owner
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: loop: Avoid updating block size under exclusive owner Syzbot came up with a reproducer where a loop device block size is changed underneath a mounted filesystem. This causes a mismatch between the block device block size and the block size stored in the superblock causing confusion in various places such as fs/buffer.c. The particular issue triggered by syzbot was a warning in __getblk_slow() due to requested buffer size not matching block device block size. Fix the problem by getting exclusive hold of the loop device to change its block size. This fails if somebody (such as filesystem) has already an exclusive ownership of the block device and thus prevents modifying the loop device under some exclusive owner which doesn't expect it.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.14 and later | 6.1.191, 6.6.109, 6.12.43, 6.15.11, 6.16.2, 6.17 | Patch available | CNA |
- Linux VendorLinux Affected 4.14 and later Fixed in 6.1.191, 6.6.109, 6.12.43, 6.15.11, 6.16.2, 6.17 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 6.6.109; 6.7 to before 6.12.43; 6.13 to before 6.15.11; 6.16 to before 6.16.2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 6.6.109; 6.7 to before 6.12.43; 6.13 to before 6.15.11; 6.16 to before 6.16.2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.1.191, 6.6.109, 6.12.43, 6.15.11, 6.16.2, 6.17
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-38709
- 2026-10-03 Alias added: GHSA-4rvm-hh4p-2jfj
- 2026-10-30 Fix available: Linux/Linux@46034518cae95db4abfde990c9ca1a0751855072, Linux/[email protected] · CNA
- 2026-10-30 1 new reference · CNA
- 2026-11-05 CISA SSVC decision points changed
References
Patch 5
- https://git.kernel.org/stable/c/457d2c5e112fd08dc1039b1ae39a83ec1782360d
- https://git.kernel.org/stable/c/139a000d20f2f38ce34296feddd641d730fe1c08
- https://git.kernel.org/stable/c/b928438cc87c0bf7ae078e4b7b6e14261e84c5c5
- https://git.kernel.org/stable/c/5d67b30aefeb7a949040bbb1b4e3b84c5d29a624
- https://git.kernel.org/stable/c/7e49538288e523427beedd26993d446afef1a6fb
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-38709 · CVE Program
- CVE-2025-38709 · NVD
- FIRST EPSS
- GHSA-4rvm-hh4p-2jfj · GitHub Advisory Database · CC BY 4.0
- CVE-2025-38709 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences