dmaengine: idxd: Fix double free in idxd_setup_wqs()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-415 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: dmaengine: idxd: Fix double free in idxd_setup_wqs() The clean up in idxd_setup_wqs() has had a couple bugs because the error handling is a bit subtle. It's simpler to just re-write it in a cleaner way. The issues here are: 1) If "idxd->max_wqs" is <= 0 then we call put_device(conf_dev) when "conf_dev" hasn't been initialized. 2) If kzalloc_node() fails then again "conf_dev" is invalid. It's either uninitialized or it points to the "conf_dev" from the previous iteration so it leads to a double free. It's better to free partial loop iterations within the loop and then the unwinding at the end can handle whole loop iterations. I also renamed the labels to describe what the goto does and not where the goto was located.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.1.140 to before 6.1.153; 6.6.92 to before 6.6.107; 6.12.30 to before 6.12.48; 6.14.8 to before 6.15 | 6.1.153, 6.6.107, 6.12.48, 6.15 | Patch available | CNA |
| Linux | Linux | 6.15 and later | 6.1.153, 6.6.107, 6.12.48, 6.16.8, 6.17 | Patch available | CNA |
- Linux VendorLinux Affected 6.1.140 to before 6.1.153; 6.6.92 to before 6.6.107; 6.12.30 to before 6.12.48; 6.14.8 to before 6.15 Fixed in 6.1.153, 6.6.107, 6.12.48, 6.15 Patch available CNA
- Linux VendorLinux Affected 6.15 and later Fixed in 6.1.153, 6.6.107, 6.12.48, 6.16.8, 6.17 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.1.140 to before 6.1.153; 6.6.92 to before 6.6.107; 6.12.30 to before 6.12.48; 6.14.8 to before 6.15; 6.15.1 to before 6.16.8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:-:*:*:*:*:*:* | 6.15 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc7:*:*:*:*:*:* | 6.15 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc1:*:*:*:*:*:* | 6.17 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc2:*:*:*:*:*:* | 6.17 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc3:*:*:*:*:*:* | 6.17 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc4:*:*:*:*:*:* | 6.17 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc5:*:*:*:*:*:* | 6.17 rc5 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.1.140 to before 6.1.153; 6.6.92 to before 6.6.107; 6.12.30 to before 6.12.48; 6.14.8 to before 6.15; 6.15.1 to before 6.16.8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:-:*:*:*:*:*:* Versions 6.15 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc7:*:*:*:*:*:* Versions 6.15 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc1:*:*:*:*:*:* Versions 6.17 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc2:*:*:*:*:*:* Versions 6.17 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc3:*:*:*:*:*:* Versions 6.17 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc4:*:*:*:*:*:* Versions 6.17 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc5:*:*:*:*:*:* Versions 6.17 rc5 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.1.153, 6.6.107, 6.12.48, 6.15
- Fix · CNA Linux (Linux) Fixed in 6.1.153, 6.6.107, 6.12.48, 6.16.8, 6.17
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-39870
- 2026-10-03 Alias added: GHSA-c3f5-89cx-rxg5
References
Patch 5
- https://git.kernel.org/stable/c/25e6146c2812487a88f619d5ff6efbdcd5b2bc31
- https://git.kernel.org/stable/c/df82c7901513fd0fc738052a8e6a330d92cc8ec9
- https://git.kernel.org/stable/c/ec5430d090d0b6ace8fefa290fc37e88930017d2
- https://git.kernel.org/stable/c/9f0e225635475b2285b966271d5e82cba74295b1
- https://git.kernel.org/stable/c/39aaa337449e71a41d4813be0226a722827ba606
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-39870 · CVE Program
- CVE-2025-39870 · NVD
- FIRST EPSS
- GHSA-c3f5-89cx-rxg5 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-39870 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences