dmaengine: idxd: Remove improper idxd_free
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-416 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: dmaengine: idxd: Remove improper idxd_free The call to idxd_free() introduces a duplicate put_device() leading to a reference count underflow: refcount_t: underflow; use-after-free. WARNING: CPU: 15 PID: 4428 at lib/refcount.c:28 refcount_warn_saturate+0xbe/0x110 ... Call Trace: <TASK> idxd_remove+0xe4/0x120 [idxd] pci_device_remove+0x3f/0xb0 device_release_driver_internal+0x197/0x200 driver_detach+0x48/0x90 bus_remove_driver+0x74/0xf0 pci_unregister_driver+0x2e/0xb0 idxd_exit_module+0x34/0x7a0 [idxd] __do_sys_delete_module.constprop.0+0x183/0x280 do_syscall_64+0x54/0xd70 entry_SYSCALL_64_after_hwframe+0x76/0x7e The idxd_unregister_devices() which is invoked at the very beginning of idxd_remove(), already takes care of the necessary put_device() through the following call path: idxd_unregister_devices() -> device_unregister() -> put_device() In addition, when CONFIG_DEBUG_KOBJECT_RELEASE is enabled, put_device() may trigger asynchronous cleanup via schedule_delayed_work(). If idxd_free() is called immediately after, it can result in a use-after-free. Remove the improper idxd_free() to avoid both the refcount underflow and potential memory corruption during module unload.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.1.140 to before 6.1.160; 6.6.92 to before 6.6.107; 6.12.30 to before 6.12.48; 6.14.8 to before 6.15 | 6.1.160, 6.6.107, 6.12.48, 6.15 | Patch available | CNA |
| Linux | Linux | 6.15 and later | 6.1.160, 6.6.107, 6.12.48, 6.16.8, 6.17 | Patch available | CNA |
- Linux VendorLinux Affected 6.1.140 to before 6.1.160; 6.6.92 to before 6.6.107; 6.12.30 to before 6.12.48; 6.14.8 to before 6.15 Fixed in 6.1.160, 6.6.107, 6.12.48, 6.15 Patch available CNA
- Linux VendorLinux Affected 6.15 and later Fixed in 6.1.160, 6.6.107, 6.12.48, 6.16.8, 6.17 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.1.140 to before 6.2; 6.6.92 to before 6.6.107; 6.12.30 to before 6.12.48; 6.14.8 to before 6.15; 6.15.1 to before 6.16.8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:-:*:*:*:*:*:* | 6.15 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc7:*:*:*:*:*:* | 6.15 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc1:*:*:*:*:*:* | 6.17 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc2:*:*:*:*:*:* | 6.17 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc3:*:*:*:*:*:* | 6.17 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc4:*:*:*:*:*:* | 6.17 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc5:*:*:*:*:*:* | 6.17 rc5 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.1.140 to before 6.2; 6.6.92 to before 6.6.107; 6.12.30 to before 6.12.48; 6.14.8 to before 6.15; 6.15.1 to before 6.16.8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:-:*:*:*:*:*:* Versions 6.15 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc7:*:*:*:*:*:* Versions 6.15 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc1:*:*:*:*:*:* Versions 6.17 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc2:*:*:*:*:*:* Versions 6.17 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc3:*:*:*:*:*:* Versions 6.17 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc4:*:*:*:*:*:* Versions 6.17 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc5:*:*:*:*:*:* Versions 6.17 rc5 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.1.160, 6.6.107, 6.12.48, 6.15
- Fix · CNA Linux (Linux) Fixed in 6.1.160, 6.6.107, 6.12.48, 6.16.8, 6.17
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-39871
- 2026-10-03 Alias added: GHSA-frjr-mhww-g3pw
References
Patch 4
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-39871 · CVE Program
- CVE-2025-39871 · NVD
- FIRST EPSS
- GHSA-frjr-mhww-g3pw · GitHub Advisory Database · CC BY 4.0
- CVE-2025-39871 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences