pcmcia: Add error handling for add_interval() in do_validate_mem()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-476.
Summary
In the Linux kernel, the following vulnerability has been resolved: pcmcia: Add error handling for add_interval() in do_validate_mem() In the do_validate_mem(), the call to add_interval() does not handle errors. If kmalloc() fails in add_interval(), it could result in a null pointer being inserted into the linked list, leading to illegal memory access when sub_interval() is called next. This patch adds an error handling for the add_interval(). If add_interval() returns an error, the function will return early with the error code.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.34 and later | 5.4.299, 5.10.243, 5.15.192, 6.1.151, 6.6.105, 6.12.46, 6.16.6, 6.17 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.34 and later Fixed in 5.4.299, 5.10.243, 5.15.192, 6.1.151, 6.6.105, 6.12.46, 6.16.6, 6.17 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.34 to before 5.4.299; 5.5 to before 5.10.243; 5.11 to before 5.15.192; 5.16 to before 6.1.151; 6.2 to before 6.6.105; 6.7 to before 6.12.46; 6.13 to before 6.16.6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc1:*:*:*:*:*:* | 6.17 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc2:*:*:*:*:*:* | 6.17 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc3:*:*:*:*:*:* | 6.17 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc4:*:*:*:*:*:* | 6.17 rc4 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.34 to before 5.4.299; 5.5 to before 5.10.243; 5.11 to before 5.15.192; 5.16 to before 6.1.151; 6.2 to before 6.6.105; 6.7 to before 6.12.46; 6.13 to before 6.16.6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc1:*:*:*:*:*:* Versions 6.17 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc2:*:*:*:*:*:* Versions 6.17 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc3:*:*:*:*:*:* Versions 6.17 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc4:*:*:*:*:*:* Versions 6.17 rc4 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.299, 5.10.243, 5.15.192, 6.1.151, 6.6.105, 6.12.46, 6.16.6, 6.17
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-39920
- 2026-10-03 Alias added: GHSA-3gqp-rpmv-vmwg
References
Patch 8
- https://git.kernel.org/stable/c/5b60ed401b47897352c520bc724c85aa908dedcc
- https://git.kernel.org/stable/c/ae184024ef31423e5beb44cf4f52999bbcf2fe5b
- https://git.kernel.org/stable/c/85be7ef8c8e792a414940a38d94565dd48d2f236
- https://git.kernel.org/stable/c/06b26e3099207c94b3d1be8565aedc6edc4f0a60
- https://git.kernel.org/stable/c/8699358b6ac99b8ccc97ed9e6e3669ef8958ef7b
- https://git.kernel.org/stable/c/289b58f8ff3198d091074a751d6b8f6827726f3e
- https://git.kernel.org/stable/c/369bf6e241506583f4ee7593c53b92e5a9f271b4
- https://git.kernel.org/stable/c/4a81f78caa53e0633cf311ca1526377d9bff7479
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-39920 · CVE Program
- CVE-2025-39920 · NVD
- FIRST EPSS
- GHSA-3gqp-rpmv-vmwg · GitHub Advisory Database · CC BY 4.0
- CVE-2025-39920 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences