i2c: rtl9300: ensure data length is within supported range
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: i2c: rtl9300: ensure data length is within supported range Add an explicit check for the xfer length to 'rtl9300_i2c_config_xfer' to ensure the data length isn't within the supported range. In particular a data length of 0 is not supported by the hardware and causes unintended or destructive behaviour. This limitation becomes obvious when looking at the register documentation [1]. 4 bits are reserved for DATA_WIDTH and the value of these 4 bits is used as N + 1, allowing a data length range of 1 <= len <= 16. Affected by this is the SMBus Quick Operation which works with a data length of 0. Passing 0 as the length causes an underflow of the value due to: (len - 1) & 0xf and effectively specifying a transfer length of 16 via the registers. This causes a 16-byte write operation instead of a Quick Write. For example, on SFP modules without write-protected EEPROM this soft-bricks them by overwriting some initial bytes. For completeness, also add a quirk for the zero length. [1] https://svanheule.net/realtek/longan/register/i2c_mst1_ctrl2
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.13 and later | 6.16.8, 6.17 | Patch available | CNA |
- Linux VendorLinux Affected 6.13 and later Fixed in 6.16.8, 6.17 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.13 to before 6.16.8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc1:*:*:*:*:*:* | 6.17 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc2:*:*:*:*:*:* | 6.17 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc3:*:*:*:*:*:* | 6.17 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc4:*:*:*:*:*:* | 6.17 rc4 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.13 to before 6.16.8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc1:*:*:*:*:*:* Versions 6.17 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc2:*:*:*:*:*:* Versions 6.17 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc3:*:*:*:*:*:* Versions 6.17 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc4:*:*:*:*:*:* Versions 6.17 rc4 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.16.8, 6.17
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-39928
- 2026-10-03 Alias added: GHSA-m43q-hvcx-4pxc
- 2026-11-07 Affected versions changed · Red Hat
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-39928 · CVE Program
- CVE-2025-39928 · NVD
- FIRST EPSS
- GHSA-m43q-hvcx-4pxc · GitHub Advisory Database · CC BY 4.0
- CVE-2025-39928 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences