fbcon: fix integer overflow in fbcon_do_set_font
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-190 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: fbcon: fix integer overflow in fbcon_do_set_font Fix integer overflow vulnerabilities in fbcon_do_set_font() where font size calculations could overflow when handling user-controlled font parameters. The vulnerabilities occur when: 1. CALC_FONTSZ(h, pitch, charcount) performs h * pith * charcount multiplication with user-controlled values that can overflow. 2. FONT_EXTRA_WORDS * sizeof(int) + size addition can also overflow 3. This results in smaller allocations than expected, leading to buffer overflows during font data copying. Add explicit overflow checking using check_mul_overflow() and check_add_overflow() kernel helpers to safety validate all size calculations before allocation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.4.62 to before 5.4.300; 4.4.235 to before 4.5; 4.9.235 to before 4.10; 4.14.196 to before 4.15; 4.19.143 to before 4.20; 5.8.6 to before 5.9 | 5.4.300, 4.5, 4.10, 4.15, 4.20, 5.9 | Patch available | CNA |
| Linux | Linux | 5.9 and later | 5.4.300, 5.10.245, 5.15.194, 6.1.155, 6.6.109, 6.12.50, 6.16.10, 6.17 | Patch available | CNA |
- Linux VendorLinux Affected 5.4.62 to before 5.4.300; 4.4.235 to before 4.5; 4.9.235 to before 4.10; 4.14.196 to before 4.15; 4.19.143 to before 4.20; 5.8.6 to before 5.9 Fixed in 5.4.300, 4.5, 4.10, 4.15, 4.20, 5.9 Patch available CNA
- Linux VendorLinux Affected 5.9 and later Fixed in 5.4.300, 5.10.245, 5.15.194, 6.1.155, 6.6.109, 6.12.50, 6.16.10, 6.17 Patch available CNA
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.4.235 to before 4.5; 4.9.235 to before 4.10; 4.14.196 to before 4.15; 4.19.143 to before 4.20; 5.4.62 to before 5.4.300; 5.8.6 to before 5.9; 5.9.1 to before 5.10.245; 5.11 to before 5.15.194; 5.16 to before 6.1.155; 6.2 to before 6.6.109; 6.7 to before 6.12.50; 6.13 to before 6.16.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:-:*:*:*:*:*:* | 5.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc3:*:*:*:*:*:* | 5.9 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc4:*:*:*:*:*:* | 5.9 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc5:*:*:*:*:*:* | 5.9 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc6:*:*:*:*:*:* | 5.9 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc7:*:*:*:*:*:* | 5.9 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc8:*:*:*:*:*:* | 5.9 rc8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc1:*:*:*:*:*:* | 6.17 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc2:*:*:*:*:*:* | 6.17 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.4.235 to before 4.5; 4.9.235 to before 4.10; 4.14.196 to before 4.15; 4.19.143 to before 4.20; 5.4.62 to before 5.4.300; 5.8.6 to before 5.9; 5.9.1 to before 5.10.245; 5.11 to before 5.15.194; 5.16 to before 6.1.155; 6.2 to before 6.6.109; 6.7 to before 6.12.50; 6.13 to before 6.16.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:-:*:*:*:*:*:* Versions 5.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc3:*:*:*:*:*:* Versions 5.9 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc4:*:*:*:*:*:* Versions 5.9 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc5:*:*:*:*:*:* Versions 5.9 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc6:*:*:*:*:*:* Versions 5.9 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc7:*:*:*:*:*:* Versions 5.9 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc8:*:*:*:*:*:* Versions 5.9 rc8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc1:*:*:*:*:*:* Versions 6.17 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc2:*:*:*:*:*:* Versions 6.17 rc2 Vulnerable ·Linux
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:6.17:rc3:*:*:*:*:*:* | 6.17 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc4:*:*:*:*:*:* | 6.17 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc5:*:*:*:*:*:* | 6.17 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc6:*:*:*:*:*:* | 6.17 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.17:rc7:*:*:*:*:*:* | 6.17 rc7 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:6.17:rc3:*:*:*:*:*:* Versions 6.17 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc4:*:*:*:*:*:* Versions 6.17 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc5:*:*:*:*:*:* Versions 6.17 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc6:*:*:*:*:*:* Versions 6.17 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.17:rc7:*:*:*:*:*:* Versions 6.17 rc7 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.300, 4.5, 4.10, 4.15, 4.20, 5.9
- Fix · CNA Linux (Linux) Fixed in 5.4.300, 5.10.245, 5.15.194, 6.1.155, 6.6.109, 6.12.50, 6.16.10, 6.17
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Not affected: 2 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2025-39967
- 2026-10-03 Alias added: GHSA-xjw8-49g8-mg8p
References
Patch 8
- https://git.kernel.org/stable/c/994bdc2d23c79087fbf7dcd9544454e8ebcef877
- https://git.kernel.org/stable/c/9c8ec14075c5317edd6b242f1be8167aa1e4e333
- https://git.kernel.org/stable/c/b8a6e85328aeb9881531dbe89bcd2637a06c3c95
- https://git.kernel.org/stable/c/a6eb9f423b3db000aaedf83367b8539f6b72dcfc
- https://git.kernel.org/stable/c/adac90bb1aaf45ca66f9db8ac100be16750ace78
- https://git.kernel.org/stable/c/4a4bac869560f943edbe3c2b032062f6673b13d3
- https://git.kernel.org/stable/c/c0c01f9aa08c8e10e10e8c9ebb5be01a4eff6eb7
- https://git.kernel.org/stable/c/1a194e6c8e1ee745e914b0b7f50fa86c89ed13fe
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-39967 · CVE Program
- CVE-2025-39967 · NVD
- FIRST EPSS
- GHSA-xjw8-49g8-mg8p · GitHub Advisory Database · CC BY 4.0
- CVE-2025-39967 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences