Kea crash upon interaction between specific client options and subnet selection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-476.
Summary
If a DHCPv4 client sends a request with some specific options, and Kea fails to find an appropriate subnet for the client, the `kea-dhcp4` process will abort with an assertion failure. This happens only if the client request is unicast directly to Kea; broadcast messages do not cause the problem. This issue affects Kea versions 2.7.1 through 2.7.9, 3.0.0, and 3.1.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Kea (ISC) Fixed in 2.6.0
Red Hat 1 advisory
- RHSA-2025:21006 Released 2025-11-11 · Red Hat rating Importantkea security update
- Red Hat Enterprise Linux AppStream (v. 10) kea-doc-3.0.1-1.el10_1, kea-hooks-3.0.1-1.el10_1
- Red Hat Enterprise Linux BaseOS (v. 10) kea-3.0.1-1.el10_1, kea-libs-3.0.1-1.el10_1
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) kea-keama-3.0.1-1.el10_1
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2025:21006 |
| Red Hat Enterprise Linux BaseOS (v. 10) | Fixed | RHSA-2025:21006 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) | Fixed | RHSA-2025:21006 |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-40779
- 2026-10-03 Alias added: GHSA-v32h-8f7r-3543
- 2026-10-07 Priority changed: LOW → MEDIUM
References
Advisory 1
More ISC vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-1999-00042 Command execution via shell metachars in INN daemon (innd) 1.5 using "newgroup" and… CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2025-27240 Cache poisoning attacks with unsolicited RRs CVSS 3.1HIGH 8.6
Sources
- CVE-2025-40779 · CVE Program
- CVE-2025-40779 · NVD
- FIRST EPSS
- GHSA-v32h-8f7r-3543 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-40779 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences