CryptX for Perl before version 0.065 contains a dependency that may be susceptible to…
Priority HIGH 76CWE-1395Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode. CryptX embeds the tomcrypt library. The versions of that library in CryptX before 0.065 may be susceptible to CVE-2019-17362.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00427 37th percentileScored 2026-11-07
Fix Fixed CryptX (MIK): 0.065
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA CryptX (MIK) Fixed in 0.065
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-40912
- 2026-10-03 Alias added: GHSA-w3qg-5chj-8g9g
References
More MIK vulnerabilities
- TI-2025-27308 Perl CryptX before version 0.087 contains a dependency that may be susceptible to an… CVSS 3.1CRITICAL 9.8
- TI-2026-30120 Stack-based buffer overflow in MIK CryptX CVSS 3.1HIGH 7.5
- TI-2026-07597 Crypt::ScryptKDF versions through 0.010 for Perl uses insecure random number source when… CVSS 3.1MEDIUM 4.8
- TI-2026-11599 CryptX versions before 0.088_001 for Perl compare AEAD authentication tags in… CVSS 3.1LOW 3.7
Sources
- CVE-2025-40912 · CVE Program
- CVE-2025-40912 · NVD
- FIRST EPSS
- GHSA-w3qg-5chj-8g9g · GitHub Advisory Database · CC BY 4.0
- CVE-2025-40912 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences