CVE-2025-41232: Spring Security authorization bypass for method security annotations on private methods
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-693.
Summary
Spring Security Aspects may not correctly locate method security annotations on private methods. This can cause an authorization bypass. Your application may be affected by this if the following are true: * You are using @EnableMethodSecurity(mode=ASPECTJ) and spring-security-aspects, and * You have Spring Security method annotations on a private method In that case, the target method may be able to be invoked without proper authorization. You are not affected if: * You are not using @EnableMethodSecurity(mode=ASPECTJ) or spring-security-aspects, or * You have no Spring Security-annotated private methods
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| VMware | Spring Security | 6.4.x to before 6.4.6 | 6.4.6 | Patch available | CNA |
| — | org.springframework.security:spring-security-aspects (Maven) | 6.4.0 to before 6.4.6 | 6.4.6 | Patch available | GHSA-9pp5-9c7g-4r83 |
| — | org.springframework.security:spring-security-core (Maven) | 6.4.0 to before 6.4.6 | 6.4.6 | Patch available | GHSA-9pp5-9c7g-4r83 |
- Spring Security VendorVMware Affected 6.4.x to before 6.4.6 Fixed in 6.4.6 Patch available CNA
- org.springframework.security:spring-security-aspects (Maven) Vendor— Affected 6.4.0 to before 6.4.6 Fixed in 6.4.6 Patch available GHSA-9pp5-9c7g-4r83
- org.springframework.security:spring-security-core (Maven) Vendor— Affected 6.4.0 to before 6.4.6 Fixed in 6.4.6 Patch available GHSA-9pp5-9c7g-4r83
Remediation
- Fix · CNA Spring Security (Spring) Fixed in 6.4.6
- Fix · GHSA-9pp5-9c7g-4r83 org.springframework.security:spring-security-aspects (Maven) Fixed in 6.4.6 Advisory →
- Fix · GHSA-9pp5-9c7g-4r83 org.springframework.security:spring-security-core (Maven) Fixed in 6.4.6 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 13 products
- A-MQ Clients 2
- OpenShift Developer Tools and Services
- Red Hat Data Grid 8
- Red Hat Fuse 7
- Red Hat Integration Camel K 1
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat JBoss Enterprise Application Platform 8
- Red Hat JBoss Enterprise Application Platform Expansion Pack
- Red Hat Process Automation 7
- Red Hat Single Sign-On 7
- Red Hat build of Apache Camel for Spring Boot 4
- Red Hat build of Quarkus
- streams for Apache Kafka
Timeline
- 2026-10-02 Threatist record created from CVE-2025-41232
- 2026-10-03 Alias added: GHSA-9pp5-9c7g-4r83
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
Other 5
- http://spring.io/security/cve-2025-41232
- https://github.com/spring-projects/spring-security/commit/bf2aaa1b1830e534ba651d422545ac08a115151b
- https://github.com/spring-projects/spring-security/commit/c972de5369a1261ab674a3f5e3a80e8ce3e8cdfb
- https://github.com/spring-projects/spring-security
- https://github.com/spring-projects/spring-security/releases/tag/6.4.6
More VMware vulnerabilities
- TI-2026-42442 vCenter directory-traversal vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26040 Privilege escalation in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26039 Heap-overflow in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-24610 Out-of-bounds write in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2023-16914 VMware vCenter Server Out-of-Bounds Write Vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2023-07303 Command injection in Aria Operations for Networks KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-41232 · CVE Program
- CVE-2025-41232 · NVD
- FIRST EPSS
- GHSA-9pp5-9c7g-4r83 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-41232 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences