Dell Wireless 5932e and Qualcomm Snapdragon X62 Firmware and GNSS/GPS Driver, versions…
Priority LOW 35CWE-428Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-428.
Summary
Dell Wireless 5932e and Qualcomm Snapdragon X62 Firmware and GNSS/GPS Driver, versions prior to 3.2.0.22 contain an Unquoted Search Path or Element vulnerability. A low privileged attacker with local access could potentially exploit this vulnerability, leading to Code Execution.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00169 6th percentileScored 2026-11-07
Fix Fixed Wireless 5932e (Dell): 3.2.0.22
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Wireless 5932e | N/A to before 3.2.0.22 | 3.2.0.22 | Patch available | CNA |
- Wireless 5932e VendorDell Affected N/A to before 3.2.0.22 Fixed in 3.2.0.22 Patch available CNA
CPE configurations NVD · 28
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:pro_rugged_13_ra13250_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:pro_rugged_13_ra13250:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:pro_rugged_14_rb14250_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:pro_rugged_14_rb14250:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_5350_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_5350:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitutde_5450_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitutde_5450:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_5550_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_5550:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:pro_rugged_13_ra13250_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:pro_rugged_13_ra13250:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:pro_rugged_14_rb14250_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:pro_rugged_14_rb14250:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_5350_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_5350:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitutde_5450_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:latitutde_5450:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_5550_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_5550:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Show 18 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:latitude_7030_rugged_extreme_tablet_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_7030_rugged_extreme_tablet:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_7350_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_7350:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_7350_detachable_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_7350_detachable:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_7450_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_7450:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_7650_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_7650:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_9450_2-in-1_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_9450_2-in-1:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:mobile_precision_3591_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:mobile_precision_3591:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:precision_3490_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:precision_3490:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:precision_3590_firmware:*:*:*:*:*:*:*:* | before 3.2.0.22 | Vulnerable | Dell |
| cpe:2.3:h:dell:precision_3590:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:latitude_7030_rugged_extreme_tablet_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_7030_rugged_extreme_tablet:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_7350_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_7350:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_7350_detachable_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_7350_detachable:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_7450_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_7450:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_7650_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_7650:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_9450_2-in-1_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_9450_2-in-1:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:mobile_precision_3591_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:mobile_precision_3591:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:precision_3490_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:precision_3490:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:precision_3590_firmware:*:*:*:*:*:*:*:* Versions before 3.2.0.22 Vulnerable ·Dell
- cpe:2.3:h:dell:precision_3590:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA Wireless 5932e (Dell) Fixed in 3.2.0.22
Timeline
- 2026-10-02 Threatist record created from CVE-2025-43993
- 2026-10-03 Alias added: GHSA-73rp-j5rh-m5jv
References
More Dell Latitude 5350 Firmware vulnerabilities
- TI-2024-35208 Weak authentication in Dell Client Platform BIOS CVSS 3.1HIGH 8.2
- TI-2025-21364 Stack-based buffer overflow in Dell Client Platform BIOS CVSS 3.1MEDIUM 6.9
Sources
- CVE-2025-43993 · CVE Program
- CVE-2025-43993 · NVD
- FIRST EPSS
- GHSA-73rp-j5rh-m5jv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences