RaspAP raspap-webgui 3.3.1 is vulnerable to Directory Traversal in…
Priority MEDIUM 61CWE-23Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
RaspAP raspap-webgui 3.3.1 is vulnerable to Directory Traversal in ajax/networking/get_wgkey.php. An authenticated attacker can send a crafted POST request with a path traversal payload in the `entity` parameter to overwrite arbitrary files writable by the web server via abuse of the `tee` command used in shell execution.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00604 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed billz/raspap-webgui (Packagist): 3.3.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | billz/raspap-webgui (Packagist) | before 3.3.6 | 3.3.6 | Patch available | GHSA-277f-37gw-9gmq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- billz/raspap-webgui (Packagist) Vendor— Affected before 3.3.6 Fixed in 3.3.6 Patch available GHSA-277f-37gw-9gmq
Remediation
- Fix · GHSA-277f-37gw-9gmq billz/raspap-webgui (Packagist) Fixed in 3.3.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-44163
- 2026-10-03 Alias added: GHSA-277f-37gw-9gmq
References
More Raspap-webgui vulnerabilities
- TI-2025-32128 In RaspAP raspap-webgui 3.3.2 and earlier, a command injection vulnerability exists in… CVSS 3.1CRITICAL 9.8
- TI-2024-24354 In RaspAP raspap-webgui 3.0.9 and earlier, a command injection vulnerability exists in… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-44163 · CVE Program
- CVE-2025-44163 · NVD
- FIRST EPSS
- GHSA-277f-37gw-9gmq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences