Read the docs
TI-2025-29274 Aliases CVE-2025-46557GHSA-f9c6-2f9p-82jj

Any user with view access to the XWiki space can change the authenticator

Priority MEDIUM 45CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
Low · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

XWiki is a generic wiki platform. In versions starting from 15.3-rc-1 to before 15.10.14, from 16.0.0-rc-1 to before 16.4.6, and from 16.5.0-rc-1 to before 16.10.0-rc-1, a user who can access pages located in the XWiki space (by default, anyone) can access the page XWiki.Authentication.Administration and (unless an authenticator is set in xwiki.cfg) switch to another installed authenticator. Note that, by default, there is only one authenticator available (Standard XWiki Authenticator). So, if no authenticator extension was installed, it's not really possible to do anything for an attacker. Also, in most cases, if an SSO authenticator is installed and utilized (like OIDC or LDAP for example), the worst an attacker can do is break authentication by switching back to the standard authenticator (that's because it's impossible to login to a user which does not have a stored password, and that's usually what SSO authenticator produce). This issue has been patched in versions 15.10.14, 16.4.6, and 16.10.0-rc-1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00583 48th percentileScored 2026-11-07
Fix Fixed xwiki-platform (xwiki): 15.10.14, 16.4.6, 16.10.0-rc-1org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven): 15.10.14, 16.4.6, 16.10.0-rc-1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
XWikixwiki-platform15.3-rc-1 to before 15.10.14; 16.0.0-rc-1 to before 16.4.6; 16.5.0-rc-1 to before 16.10.0-rc-115.10.14, 16.4.6, 16.10.0-rc-1Patch availableCNA
—org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven)15.3-rc-1 to before 15.10.1415.10.14Patch availableGHSA-f9c6-2f9p-82jj
—org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven)16.0.0-rc-1 to before 16.4.616.4.6Patch availableGHSA-f9c6-2f9p-82jj
—org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven)16.5.0-rc-1 to before 16.10.0-rc-116.10.0-rc-1Patch availableGHSA-f9c6-2f9p-82jj
  • xwiki-platform VendorXWiki Affected 15.3-rc-1 to before 15.10.14; 16.0.0-rc-1 to before 16.4.6; 16.5.0-rc-1 to before 16.10.0-rc-1 Fixed in 15.10.14, 16.4.6, 16.10.0-rc-1 Patch available CNA
  • org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven) Vendor— Affected 15.3-rc-1 to before 15.10.14 Fixed in 15.10.14 Patch available GHSA-f9c6-2f9p-82jj
  • org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven) Vendor— Affected 16.0.0-rc-1 to before 16.4.6 Fixed in 16.4.6 Patch available GHSA-f9c6-2f9p-82jj
  • org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven) Vendor— Affected 16.5.0-rc-1 to before 16.10.0-rc-1 Fixed in 16.10.0-rc-1 Patch available GHSA-f9c6-2f9p-82jj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:xwiki:xwiki:*:*:*:*:*:*:*:*15.3 to before 15.10.14; 16.0.0 to before 16.4.6; 16.5.0 – 16.9.0VulnerableXWiki
  • cpe:2.3:a:xwiki:xwiki:*:*:*:*:*:*:*:* Versions 15.3 to before 15.10.14; 16.0.0 to before 16.4.6; 16.5.0 – 16.9.0 Vulnerable ·XWiki

Remediation

  • Fix · CNA xwiki-platform (xwiki) Fixed in 15.10.14, 16.4.6, 16.10.0-rc-1
  • Fix · GHSA-f9c6-2f9p-82jj org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven) Fixed in 15.10.14 Advisory →
  • Fix · GHSA-f9c6-2f9p-82jj org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven) Fixed in 16.4.6 Advisory →
  • Fix · GHSA-f9c6-2f9p-82jj org.xwiki.platform:xwiki-platform-security-authentication-ui (Maven) Fixed in 16.10.0-rc-1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-46557
  2. 2026-10-03 Alias added: GHSA-f9c6-2f9p-82jj

References

  • TI-2025-18595 Remote code execution as guest via SolrSearchMacros request in xwiki KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-25214 Remote code execution through the section parameter in Administration as guest in XWiki Platform CVSS 3.1CRITICAL 10.0
  • TI-2025-23500 XWiki Platform vulnerable to SQL injection through getdeleteddocuments.vm template sort parameter CVSS 4.0CRITICAL 9.3
  • TI-2025-23979 org.xwiki.platform:xwiki-platform-rest-server allows SQL injection in query endpoint of REST API CVSS 4.0CRITICAL 9.3
  • TI-2024-20829 XWiki Platform: Remote code execution from account via SearchSuggestSourceSheet CVSS 3.1CRITICAL 10.0
  • TI-2024-14375 XWiki Remote Code Execution vulnerability via user registration CVSS 3.1CRITICAL 10.0
See all 247 →

Sources