OPA server Data API HTTP path injection of Rego
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass, Code execution, Denial of service
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-863, CWE-94 and CWE-770.
Summary
Open Policy Agent (OPA) is an open source, general-purpose policy engine. Prior to version 1.4.0, when run as a server, OPA exposes an HTTP Data API for reading and writing documents. Requesting a virtual document through the Data API entails policy evaluation, where a Rego query containing a single data document reference is constructed from the requested path. This query is then used for policy evaluation. A HTTP request path can be crafted in a way that injects Rego code into the constructed query. The evaluation result cannot be made to return any other data than what is generated by the requested path, but this path can be misdirected, and the injected Rego code can be crafted to make the query succeed or fail; opening up for oracle attacks or, given the right circumstances, erroneous policy decision results. Furthermore, the injected code can be crafted to be computationally expensive, resulting in a Denial Of Service (DoS) attack. This issue has been patched in version 1.4.0. A workaround involves having network access to OPA’s RESTful APIs being limited to `localhost` and/or trusted networks, unless necessary for production reasons.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| open-policy-agent | opa | before 1.4.0 | 1.4.0 | Patch available | CNA |
| — | github.com/open-policy-agent/opa/v1/server (Go) | before 1.4.0 | 1.4.0 | Patch available | GHSA-6m8w-jc87-6cr7 |
| — | github.com/open-policy-agent/opa/server (Go) | before 1.4.0 | 1.4.0 | Patch available | GHSA-6m8w-jc87-6cr7 |
| — | github.com/open-policy-agent/opa (Go) | before 1.4.0 | 1.4.0 | Patch available | GHSA-6m8w-jc87-6cr7 |
- opa Vendoropen-policy-agent Affected before 1.4.0 Fixed in 1.4.0 Patch available CNA
- github.com/open-policy-agent/opa/v1/server (Go) Vendor— Affected before 1.4.0 Fixed in 1.4.0 Patch available GHSA-6m8w-jc87-6cr7
- github.com/open-policy-agent/opa/server (Go) Vendor— Affected before 1.4.0 Fixed in 1.4.0 Patch available GHSA-6m8w-jc87-6cr7
- github.com/open-policy-agent/opa (Go) Vendor— Affected before 1.4.0 Fixed in 1.4.0 Patch available GHSA-6m8w-jc87-6cr7
Remediation
- Fix · CNA opa (open-policy-agent) Fixed in 1.4.0
- Fix · GHSA-6m8w-jc87-6cr7 github.com/open-policy-agent/opa/v1/server (Go) Fixed in 1.4.0 Advisory →
- Fix · GHSA-6m8w-jc87-6cr7 github.com/open-policy-agent/opa/server (Go) Fixed in 1.4.0 Advisory →
- Fix · GHSA-6m8w-jc87-6cr7 github.com/open-policy-agent/opa (Go) Fixed in 1.4.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Migration Toolkit for Virtualization | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-46569
- 2026-10-03 Alias added: GHSA-6m8w-jc87-6cr7
References
More open-policy-agent vulnerabilities
- TI-2022-16508 OPA Compiler: Bypass of WithUnsafeBuiltins using `with` keyword to mock functions CVSS 3.1CRITICAL 9.8
- TI-2022-07681 Array literal misordering in github.com/open-policy-agent/opa CVSS 3.1MEDIUM 6.3
- TI-2022-14552 An issue in the AST parser (ast/compile.go) of Open Policy Agent v0.10.2 allows attackers… CVSS 3.1HIGH 7.5
- TI-2022-11544 An issue in the component ast/parser.go of Open Policy Agent v0.39.0 causes the… CVSS 3.1HIGH 7.5
- TI-2026-21196 opa-envoy-plugin has an Authorization Bypass via Double-Slash Path Misinterpretation in `input.parsed_path` CVSS 4.0HIGH 7.1
- TI-2024-07657 OPA SMB Force-Authentication CVSS 3.1HIGH 7.3
Sources
- CVE-2025-46569 · CVE Program
- CVE-2025-46569 · NVD
- FIRST EPSS
- GHSA-6m8w-jc87-6cr7 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-46569 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences