Git GUI can create and overwrite files for which the user has write permission
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Partial Red Hat: 3 fixed, 4 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-88.
Summary
Git GUI allows you to use the Git source control management tools via a GUI. When a user clones an untrusted repository and is tricked into editing a file located in a maliciously named directory in the repository, then Git GUI can create and overwrite files for which the user has write permission. This vulnerability is fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, and 2.50.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| j6t | git-gui | before 2.43.7; 2.44.0 to before 2.44.4; 2.45.0 to before 2.45.4; 2.46.0 to before 2.46.4; 2.47.0 to before 2.47.3; 2.48.0 to before 2.48.2; 2.49.0 to before 2.49.1; 2.50.0 to before 2.50.1 | 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, 2.50.1 | Patch available | CNA |
- git-gui Vendorj6t Affected before 2.43.7; 2.44.0 to before 2.44.4; 2.45.0 to before 2.45.4; 2.46.0 to before 2.46.4; 2.47.0 to before 2.47.3; 2.48.0 to before 2.48.2; 2.49.0 to before 2.49.1; 2.50.0 to before 2.50.1 Fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, 2.50.1 Patch available CNA
Remediation
- Fix · CNA git-gui (j6t) Fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, 2.50.1
Red Hat 3 advisories
- RHSA-2025:11534 Released 2025-07-23 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream (v. 8) git-2.43.7-1.el8_10, git-all-2.43.7-1.el8_10, git-core-2.43.7-1.el8_10 +12
- RHSA-2025:11533 Released 2025-07-22 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream (v. 10) git-2.47.3-1.el10_0, git-all-2.47.3-1.el10_0, git-core-2.47.3-1.el10_0 +12
- RHSA-2025:11462 Released 2025-07-21 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream (v. 9) git-2.47.3-1.el9_6, git-all-2.47.3-1.el9_6, git-core-2.47.3-1.el9_6 +12
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Dev Spaces | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2025:11533 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2025:11534 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2025:11462 |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-46835
References
More j6t vulnerabilities
- TI-2025-20423 Gitk allows arbitrary command execution CVSS 3.1HIGH 8.6
- TI-2025-29075 Git GUI malicious command injection on Windows CVSS 3.1HIGH 8.6
- TI-2025-20422 Gitk can create and truncate files in the user's home directory CVSS 3.1LOW 3.6
Sources
- CVE-2025-46835 · CVE Program
- CVE-2025-46835 · NVD
- FIRST EPSS
- CVE-2025-46835 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences