An issue was discovered in post.php in bootstrap-multiselect (aka Bootstrap Multiselect)…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering, Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352 and CWE-79.
Summary
An issue was discovered in post.php in bootstrap-multiselect (aka Bootstrap Multiselect) 1.1.2. A PHP script in the source code echoes arbitrary POST data. If a developer adopts this structure wholesale in a live application, it could create a Reflective Cross-Site Scripting (XSS) vulnerability exploitable through Cross-Site Request Forgery (CSRF).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | bootstrap-multiselect (npm) | before 2.0.0 | 2.0.0 | Patch available | GHSA-gv5r-9gxr-v74w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- bootstrap-multiselect (npm) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-gv5r-9gxr-v74w
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:davidstutz:bootstrap_multiselect:1.1.2:*:*:*:*:*:*:* | 1.1.2 | Vulnerable | Davidstutz |
- cpe:2.3:a:davidstutz:bootstrap_multiselect:1.1.2:*:*:*:*:*:*:* Versions 1.1.2 Vulnerable ·Davidstutz
Remediation
- Fix · GHSA-gv5r-9gxr-v74w bootstrap-multiselect (npm) Fixed in 2.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-47204
- 2026-10-03 Alias added: GHSA-gv5r-9gxr-v74w
References
Patch 1
Other 5
- https://github.com/davidstutz/bootstrap-multiselect/releases
- https://github.com/davidstutz/bootstrap-multiselect/issues/1286
- https://github.com/davidstutz/bootstrap-multiselect/pull/1287
- https://github.com/davidstutz/bootstrap-multiselect/commit/7da45ded9c82837a8eae9cb9dd3bd32a3dd1dc45
- https://github.com/davidstutz/bootstrap-multiselect
Sources
- CVE-2025-47204 · CVE Program
- CVE-2025-47204 · NVD
- FIRST EPSS
- GHSA-gv5r-9gxr-v74w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences