PowSyBl Core XML Reader allows XXE and SSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-611 and the CVSS impact.
Summary
PowSyBl (Power System Blocks) is a framework to build power system oriented software. Prior to version 6.7.2, in certain places, powsybl-core XML parsing is vulnerable to an XML external entity (XXE) attack and to a server-side request forgery (SSRF) attack. This allows an attacker to elevate their privileges to read files that they do not have permissions to, including sensitive files on the system. The vulnerable class is com.powsybl.commons.xml.XmlReader which is considered to be untrusted in use cases where untrusted users can submit their XML to the vulnerable methods. This can be a multi-tenant application that hosts many different users perhaps with different privilege levels. This issue has been patched in com.powsybl:powsybl-commons: 6.7.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| powsybl | powsybl-core | before 6.7.2 | 6.7.2 | Patch available | CNA |
| — | com.powsybl:powsybl-commons (Maven) | before 6.7.2 | 6.7.2 | Patch available | GHSA-qpj9-qcwx-8jv2 |
- powsybl-core Vendorpowsybl Affected before 6.7.2 Fixed in 6.7.2 Patch available CNA
- com.powsybl:powsybl-commons (Maven) Vendor— Affected before 6.7.2 Fixed in 6.7.2 Patch available GHSA-qpj9-qcwx-8jv2
Remediation
- Fix · CNA powsybl-core (powsybl) Fixed in 6.7.2
- Fix · GHSA-qpj9-qcwx-8jv2 com.powsybl:powsybl-commons (Maven) Fixed in 6.7.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-47293
- 2026-10-03 Alias added: GHSA-qpj9-qcwx-8jv2
References
More powsybl vulnerabilities
- TI-2025-30237 PowSyBl Core allows deserialization of untrusted SparseMatrix data CVSS 4.0HIGH 8.1
- TI-2025-30429 PowSyBl Core contains Polynomial REDoS’es CVSS 4.0MEDIUM 6.3
- TI-2026-40195 PowSyBl: Command Injection in LocalCommandExecutor-s CVSS 4.0HIGH 7.1
- TI-2025-30430 PowSyBl Core Contains a Polynomial ReDoS in RegexCriterion CVSS 4.0LOW 2.7
Sources
- CVE-2025-47293 · CVE Program
- CVE-2025-47293 · NVD
- FIRST EPSS
- GHSA-qpj9-qcwx-8jv2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences