Apache ORC: Potential Heap Buffer Overflow during C++ LZO Decompression
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · High · High
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Heap-based Buffer Overflow vulnerability in Apache ORC. A vulnerability has been identified in the ORC C++ LZO decompression logic, where specially crafted malformed ORC files can cause the decompressor to allocate a 250-byte buffer but then attempts to copy 295 bytes into it. It causes memory corruption. This issue affects Apache ORC C++ library: through 1.8.8, from 1.9.0 through 1.9.5, from 2.0.0 through 2.0.4, from 2.1.0 through 2.1.1. Users are recommended to upgrade to version 1.8.9, 1.9.6, 2.0.5, and 2.1.2, which fix the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache ORC | up to 1.8.8; 1.9.0 – 1.9.5; 2.0.0 – 2.0.4; 2.1.0 – 2.1.1 | — | No fix listed | CNA |
- Apache ORC VendorApache Affected up to 1.8.8; 1.9.0 – 1.9.5; 2.0.0 – 2.0.4; 2.1.0 – 2.1.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:orc:*:*:*:*:*:*:*:* | before 1.8.9; 1.9.0 to before 1.9.6; 2.0.0 to before 2.0.5; 2.1.0 to before 2.1.2 | Vulnerable | Apache |
- cpe:2.3:a:apache:orc:*:*:*:*:*:*:*:* Versions before 1.8.9; 1.9.0 to before 1.9.6; 2.0.0 to before 2.0.5; 2.1.0 to before 2.1.2 Vulnerable ·Apache
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-47436
- 2026-10-03 Alias added: GHSA-h527-m3cp-9hm7
References
More Apache Orc vulnerabilities
- TI-2018-05792 Uncontrolled recursion in Apache ORC CVSS 3.0HIGH 7.5
Sources
- CVE-2025-47436 · CVE Program
- CVE-2025-47436 · NVD
- FIRST EPSS
- GHSA-h527-m3cp-9hm7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences