TYPO3 CMS Vulnerable to Privilege Escalation to System Maintainer
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| TYPO3 | typo3 | 10.0.0 to before 10.4.50; 11.0.0 to before 11.5.44; 12.0.0 to before 12.4.31; 13.0.0 to before 13.4.12 | 10.4.50, 11.5.44, 12.4.31, 13.4.12 | Patch available | CNA |
| — | typo3/cms-core (Packagist) | 10.4.0 to before 10.4.50 | 10.4.50 | Patch available | GHSA-6frx-j292-c844 |
| — | typo3/cms-core (Packagist) | 11.0.0 to before 11.5.44 | 11.5.44 | Patch available | GHSA-6frx-j292-c844 |
| — | typo3/cms-core (Packagist) | 12.0.0 to before 12.4.31 | 12.4.31 | Patch available | GHSA-6frx-j292-c844 |
| — | typo3/cms-core (Packagist) | 13.0.0 to before 13.4.12 | 13.4.12 | Patch available | GHSA-6frx-j292-c844 |
- typo3 VendorTYPO3 Affected 10.0.0 to before 10.4.50; 11.0.0 to before 11.5.44; 12.0.0 to before 12.4.31; 13.0.0 to before 13.4.12 Fixed in 10.4.50, 11.5.44, 12.4.31, 13.4.12 Patch available CNA
- typo3/cms-core (Packagist) Vendor— Affected 10.4.0 to before 10.4.50 Fixed in 10.4.50 Patch available GHSA-6frx-j292-c844
- typo3/cms-core (Packagist) Vendor— Affected 11.0.0 to before 11.5.44 Fixed in 11.5.44 Patch available GHSA-6frx-j292-c844
- typo3/cms-core (Packagist) Vendor— Affected 12.0.0 to before 12.4.31 Fixed in 12.4.31 Patch available GHSA-6frx-j292-c844
- typo3/cms-core (Packagist) Vendor— Affected 13.0.0 to before 13.4.12 Fixed in 13.4.12 Patch available GHSA-6frx-j292-c844
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:typo3:typo3:*:*:*:*:*:*:*:* | 10.4.0 to before 10.4.50; 11.0.0 to before 11.5.44; 12.0.0 to before 12.4.31; 13.0.0 to before 13.4.12 | Vulnerable | TYPO3 |
- cpe:2.3:a:typo3:typo3:*:*:*:*:*:*:*:* Versions 10.4.0 to before 10.4.50; 11.0.0 to before 11.5.44; 12.0.0 to before 12.4.31; 13.0.0 to before 13.4.12 Vulnerable ·TYPO3
Remediation
- Fix · CNA typo3 (TYPO3) Fixed in 10.4.50, 11.5.44, 12.4.31, 13.4.12
- Fix · GHSA-6frx-j292-c844 typo3/cms-core (Packagist) Fixed in 10.4.50 Advisory →
- Fix · GHSA-6frx-j292-c844 typo3/cms-core (Packagist) Fixed in 11.5.44 Advisory →
- Fix · GHSA-6frx-j292-c844 typo3/cms-core (Packagist) Fixed in 12.4.31 Advisory →
- Fix · GHSA-6frx-j292-c844 typo3/cms-core (Packagist) Fixed in 13.4.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-47940
- 2026-10-03 Alias added: GHSA-6frx-j292-c844
References
Advisory 3
More Typo3 vulnerabilities
- TI-2023-10314 Persisted Cross-Site Scripting in Frontend Rendering in typo3 CVSS 3.1HIGH 8.8
- TI-2010-03538 The jumpUrl (aka access tracking) implementation in tslib/class.tslib_fe.php in TYPO3… CVSS 2.0HIGH 7.1
- TI-2009-00775 The jumpUrl mechanism in class.tslib_fe.php in TYPO3 3.3.x through 3.8.x, 4.0 before… CVSS 2.0MEDIUM 5.0
- TI-2009-00241 The Indexed Search Engine (indexed_search) system extension in TYPO3 4.0.0 through 4.0.9… CVSS 2.0HIGH 10.0
- TI-2020-08940 Improperly Controlled Modification of Dynamically-Determined Object Attributes in TYPO3 CMS CVSS 3.1CRITICAL 10.0
- TI-2011-03994 Improper authentication in TYPO3 CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-47940 · CVE Program
- CVE-2025-47940 · NVD
- FIRST EPSS
- GHSA-6frx-j292-c844 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences