Read the docs
TI-2025-30696 Aliases CVE-2025-48370GHSA-8r88-6cj9-9fh5

auth-js Vulnerable to Insecure Path Routing from Malformed User Input

Priority LOW 21CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.70.0, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.70.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00902 59th percentileScored 2026-11-07
Fix Fixed auth-js (supabase): 2.70.0@supabase/auth-js (npm): 2.70.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
supabaseauth-jsbefore 2.70.02.70.0Patch availableCNA
—@supabase/auth-js (npm)before 2.70.02.70.0Patch availableGHSA-8r88-6cj9-9fh5
  • auth-js Vendorsupabase Affected before 2.70.0 Fixed in 2.70.0 Patch available CNA
  • @supabase/auth-js (npm) Vendor— Affected before 2.70.0 Fixed in 2.70.0 Patch available GHSA-8r88-6cj9-9fh5

Remediation

  • Fix · CNA auth-js (supabase) Fixed in 2.70.0
  • Fix · GHSA-8r88-6cj9-9fh5 @supabase/auth-js (npm) Fixed in 2.70.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-48370
  2. 2026-10-03 Alias added: GHSA-8r88-6cj9-9fh5

References

  • TI-2024-16040 Supabase PostgreSQL v15.1 was discovered to contain a SQL injection vulnerability via the… CVSS 3.1CRITICAL 9.8
  • TI-2026-44468 Supabase Realtime: Incorrect Authorization CVSS 3.1MEDIUM 6.5
  • TI-2026-24366 Supabase Auth has insecure Apple and Azure authentication with ID tokens CVSS 3.1MEDIUM 4.8
  • TI-2026-79331 Expired JWTs accepted by Supabase Realtime REST broadcast endpoints CVSS 3.1LOW 3.1

Sources