An issue was discovered in Django 5.2 before 5.2.3, 5.1 before 5.1.11, and 4.2 before…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 2 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
An issue was discovered in Django 5.2 before 5.2.3, 5.1 before 5.1.11, and 4.2 before 4.2.23. Internal HTTP response logging does not escape request.path, which allows remote attackers to potentially manipulate log output via crafted URLs. This may lead to log injection or forgery when logs are viewed in terminals or processed by external systems.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| djangoproject | Django | 4.2 to before 4.2.23; 5.1 to before 5.1.11; 5.2 to before 5.2.3 | 4.2.23, 5.1.11, 5.2.3 | Patch available | CNA |
| — | Django (PyPI) | 5.2 to before 5.2.2 | 5.2.2 | Patch available | GHSA-7xr5-9hcq-chf9 |
| — | Django (PyPI) | 5.0a1 to before 5.1.10 | 5.1.10 | Patch available | GHSA-7xr5-9hcq-chf9 |
| — | Django (PyPI) | before 4.2.22 | 4.2.22 | Patch available | GHSA-7xr5-9hcq-chf9 |
- Django Vendordjangoproject Affected 4.2 to before 4.2.23; 5.1 to before 5.1.11; 5.2 to before 5.2.3 Fixed in 4.2.23, 5.1.11, 5.2.3 Patch available CNA
- Django (PyPI) Vendor— Affected 5.2 to before 5.2.2 Fixed in 5.2.2 Patch available GHSA-7xr5-9hcq-chf9
- Django (PyPI) Vendor— Affected 5.0a1 to before 5.1.10 Fixed in 5.1.10 Patch available GHSA-7xr5-9hcq-chf9
- Django (PyPI) Vendor— Affected before 4.2.22 Fixed in 4.2.22 Patch available GHSA-7xr5-9hcq-chf9
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 4.2 to before 4.2.23; 5.1 to before 5.1.11; 5.2 to before 5.2.3 | Vulnerable | djangoproject |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 4.2 to before 4.2.23; 5.1 to before 5.1.11; 5.2 to before 5.2.3 Vulnerable ·djangoproject
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA Django (djangoproject) Fixed in 4.2.23, 5.1.11, 5.2.3
- Fix · GHSA-7xr5-9hcq-chf9 Django (PyPI) Fixed in 5.2.2 Advisory →
- Fix · GHSA-7xr5-9hcq-chf9 Django (PyPI) Fixed in 5.1.10 Advisory →
- Fix · GHSA-7xr5-9hcq-chf9 Django (PyPI) Fixed in 4.2.22 Advisory →
Red Hat 2 advisories
- RHSA-2025:16487 Released 2025-09-23 · Red Hat rating ImportantRed Hat Ansible Automation Platform 2.5 Product Security and Bug Fix Update
- Red Hat Ansible Automation Platform 2.5 for RHEL 8 automation-controller-venv-tower-4.6.20-1.el8ap, python3.11-django-4.2.24-1.el8ap
- Red Hat Ansible Automation Platform 2.5 for RHEL 9 automation-controller-venv-tower-4.6.20-1.el9ap, python3.11-django-4.2.24-1.el9ap
- RHSA-2025:14686 Released 2025-08-26 · Red Hat rating ModerateRed Hat Ansible Automation Platform 2.5 Product Security and Bug Fix Update
- Red Hat Ansible Automation Platform 2.5 for RHEL 8 automation-controller-4.6.19-1.el8ap, automation-controller-cli-4.6.19-1.el8ap, automation-controller-server-4.6.19-1.el8ap +3
- Red Hat Ansible Automation Platform 2.5 for RHEL 9 automation-controller-4.6.19-1.el9ap, automation-controller-cli-4.6.19-1.el9ap, automation-controller-server-4.6.19-1.el9ap +3
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Discovery 1 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet |
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | Fixed | RHSA-2025:14686, RHSA-2025:16487 |
| Red Hat Ansible Automation Platform 2.5 for RHEL 9 | Fixed | RHSA-2025:14686, RHSA-2025:16487 |
Not affected: 3 products
- Red Hat Ansible Automation Platform 2
- Red Hat Ansible Automation Platform 2.5 for RHEL 8
- Red Hat Ansible Automation Platform 2.5 for RHEL 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-48432
- 2026-10-03 Alias added: GHSA-7xr5-9hcq-chf9
References
Advisory 7
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/g/django-announce
- https://www.djangoproject.com/weblog/2025/jun/04/security-releases/
- https://nvd.nist.gov/vuln/detail/CVE-2025-48432
- http://www.openwall.com/lists/oss-security/2025/06/04/5
- http://www.openwall.com/lists/oss-security/2025/06/10/2
- http://www.openwall.com/lists/oss-security/2025/06/10/3
Other 7
- https://www.djangoproject.com/weblog/2025/jun/10/bugfix-releases/
- https://docs.djangoproject.com/en/dev/releases/security
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2025-47.yaml
- https://www.djangoproject.com/weblog/2025/jun/04/security-releases
- https://www.djangoproject.com/weblog/2025/jun/10/bugfix-releases
- http://www.openwall.com/lists/oss-security/2025/06/10/4
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-48432 · CVE Program
- CVE-2025-48432 · NVD
- FIRST EPSS
- GHSA-7xr5-9hcq-chf9 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-48432 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences