Chrome PHP is missing encoding in `CssSelector`
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Chrome PHP allows users to start playing with chrome/chromium in headless mode from PHP. Prior to version 1.14.0, CSS Selector expressions are not properly encoded, which can lead to XSS (cross-site scripting) vulnerabilities. This is patched in v1.14.0. As a workaround, users can apply encoding manually to their selectors if they are unable to upgrade.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| chrome-php | chrome | before 1.14.0 | 1.14.0 | Patch available | CNA |
| — | chrome-php/chrome (Packagist) | before 1.14.0 | 1.14.0 | Patch available | GHSA-3432-fmrf-7vmh |
- chrome Vendorchrome-php Affected before 1.14.0 Fixed in 1.14.0 Patch available CNA
- chrome-php/chrome (Packagist) Vendor— Affected before 1.14.0 Fixed in 1.14.0 Patch available GHSA-3432-fmrf-7vmh
Remediation
- Fix · CNA chrome (chrome-php) Fixed in 1.14.0
- Fix · GHSA-3432-fmrf-7vmh chrome-php/chrome (Packagist) Fixed in 1.14.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-48883
- 2026-10-03 Alias added: GHSA-3432-fmrf-7vmh
References
Sources
- CVE-2025-48883 · CVE Program
- CVE-2025-48883 · NVD
- FIRST EPSS
- GHSA-3432-fmrf-7vmh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences