Read the docs
TI-2025-31227 Aliases CVE-2025-49147GHSA-pgvc-6h2p-q4f6

Umbraco.Cms Vulnerable to Disclosure of Configured Password Requirements

Priority LOW 30CWE-497Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-497.

Summary

Umbraco, a free and open source .NET content management system, has a vulnerability in versions 10.0.0 through 10.8.10 and 13.0.0 through 13.9.1. Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password. This information was not exposed in Umbraco 7 or 8, nor in 14 or higher versions. The vulnerability is patched in versions 10.8.11 and 13.9.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00343 27th percentileScored 2026-11-07
Fix Fixed Umbraco-CMS (umbraco): 10.8.111, 13.9.2Umbraco.Cms (NuGet): 10.8.11, 13.9.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
umbracoUmbraco-CMS10.0.0 to before 10.8.111; 13.0.0 to before 13.9.210.8.111, 13.9.2Patch availableCNA
—Umbraco.Cms (NuGet)10.0.0 to before 10.8.1110.8.11Patch availableGHSA-pgvc-6h2p-q4f6
—Umbraco.Cms (NuGet)13.0.0 to before 13.9.213.9.2Patch availableGHSA-pgvc-6h2p-q4f6
  • Umbraco-CMS Vendorumbraco Affected 10.0.0 to before 10.8.111; 13.0.0 to before 13.9.2 Fixed in 10.8.111, 13.9.2 Patch available CNA
  • Umbraco.Cms (NuGet) Vendor— Affected 10.0.0 to before 10.8.11 Fixed in 10.8.11 Patch available GHSA-pgvc-6h2p-q4f6
  • Umbraco.Cms (NuGet) Vendor— Affected 13.0.0 to before 13.9.2 Fixed in 13.9.2 Patch available GHSA-pgvc-6h2p-q4f6

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:umbraco:umbraco_cms:*:*:*:*:*:*:*:*10.0.0 to before 10.8.11; 13.0.0 to before 13.9.2Vulnerableumbraco
  • cpe:2.3:a:umbraco:umbraco_cms:*:*:*:*:*:*:*:* Versions 10.0.0 to before 10.8.11; 13.0.0 to before 13.9.2 Vulnerable ·umbraco

Remediation

  • Fix · CNA Umbraco-CMS (umbraco) Fixed in 10.8.111, 13.9.2
  • Fix · GHSA-pgvc-6h2p-q4f6 Umbraco.Cms (NuGet) Fixed in 10.8.11 Advisory →
  • Fix · GHSA-pgvc-6h2p-q4f6 Umbraco.Cms (NuGet) Fixed in 13.9.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-49147
  2. 2026-10-03 Alias added: GHSA-pgvc-6h2p-q4f6

References

  • TI-2025-41183 An arbitrary file upload vulnerability in Umbraco CMS v16.3.3 allows attackers to execute… CVSS 3.1CRITICAL 10.0
  • TI-2012-05477 Umbraco CMS < 4.7.1 codeEditorSave.asmx RCE CVSS 4.0CRITICAL 9.3
  • TI-2021-22392 Umbraco v8.14.1 - 'baseUrl' SSRF CVSS 4.0MEDIUM 6.9
  • TI-2024-36846 A stored cross-site scripting (XSS) vulnerability in Umbraco CMS v14.3.1 allows attackers… CVSS 3.1MEDIUM 6.5
  • TI-2019-15240 Umbraco CMS 4.11.8 through 7.15.10, and 7.12.4, allows Remote Code Execution by… CVSS 3.1HIGH 7.2
  • TI-2020-04738 Cross-site scripting in Umbraco CMS CVSS 3.1MEDIUM 5.4
See all 56 →

Sources