Read the docs
TI-2025-32119 Aliases CVE-2025-50383GHSA-2f28-69j7-85hf

alextselegidis Easy!Appointments v1.5.1 was discovered to contain a SQL injection…

Priority HIGH 74CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

alextselegidis Easy!Appointments v1.5.1 was discovered to contain a SQL injection vulnerability via the order_by parameter.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00365 30th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed alextselegidis/easyappointments (Packagist): 1.5.2-beta.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—alextselegidis/easyappointments (Packagist)before 1.5.2-beta.11.5.2-beta.1Patch availableGHSA-2f28-69j7-85hf
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • alextselegidis/easyappointments (Packagist) Vendor— Affected before 1.5.2-beta.1 Fixed in 1.5.2-beta.1 Patch available GHSA-2f28-69j7-85hf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:easyappointments:easy\!appointments:1.5.1:*:*:*:*:-:*:*1.5.1Vulnerablealextselegidis
  • cpe:2.3:a:easyappointments:easy\!appointments:1.5.1:*:*:*:*:-:*:* Versions 1.5.1 Vulnerable ·alextselegidis

Remediation

  • Fix · GHSA-2f28-69j7-85hf alextselegidis/easyappointments (Packagist) Fixed in 1.5.2-beta.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-50383
  2. 2026-10-03 Alias added: GHSA-2f28-69j7-85hf

References

  • TI-2026-19023 CSRF Protection Bypass: Sensitive endpoints accept GET requests, enabling admin account takeover CVSS 4.0HIGH 7.4
  • TI-2025-21080 Booking logic flaw in Easy!Appointments v1.5.1 allows unauthenticated attackers to create… CVSS 3.1HIGH 7.5
  • TI-2025-22965 WordPress Easy!Appointments plugin <= 1.4.2 - Cross Site Request Forgery (CSRF) to Settings Change vulnerability CVSS 3.1HIGH 8.8
  • TI-2018-09371 Easy!Appointments 1.3.0 has a Missing Authorization issue allowing retrieval of hashed passwords and salts. CVSS 3.1HIGH 7.5
  • TI-2018-09370 Easy!Appointments 1.3.0 has a Guessable CAPTCHA issue. CVSS 3.1MEDIUM 6.5
  • TI-2024-00643 Easy!Appointments <= 1.3.1 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
See all 8 →

Sources