Read the docs
TI-2025-32916 Aliases CVE-2025-52880

Komga Vulnerable to Arbitrary Code Execution via Crafted EPUB File

Priority LOW 20CWE-799Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

Komga is a media server for comics, mangas, BDs, magazines and eBooks. A Cross-Site Scripting (XSS) vulnerability has been discovered in versions 1.8.0 through 1.21.3 when serving EPUB resources, either directly from the API, or when reading using the epub reader. The vulnerability lets an attacker perform actions on the victim's behalf. When targeting an admin user, this can be combined with controlling a server-side command to achieve arbitrary code execution. For this vulnerability to be exploited, a malicious EPUB file has to be present in a Komga library, and subsequently accessed in the Epub reader by an admin user. Version 1.22.0 contains a patch for the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00322 25th percentileScored 2026-11-07
Fix Fixed komga (gotson): 1.22.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
gotsonkomga1.8.0 to before 1.22.01.22.0Patch availableCNA
  • komga Vendorgotson Affected 1.8.0 to before 1.22.0 Fixed in 1.22.0 Patch available CNA

Remediation

  • Fix · CNA komga (gotson) Fixed in 1.22.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-52880

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences