@cyanheads/git-mcp-server vulnerable to command injection in several tools
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
@cyanheads/git-mcp-server is an MCP server designed to interact with Git repositories. Prior to version 2.1.5, there is a command injection vulnerability caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). An MCP Client can be instructed to execute additional actions for example via indirect prompt injection when asked to read git logs. This issue has been patched in version 2.1.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| cyanheads | git-mcp-server | before 2.1.5 | 2.1.5 | Patch available | CNA |
| — | @cyanheads/git-mcp-server (npm) | before 2.1.5 | 2.1.5 | Patch available | GHSA-3q26-f695-pp76 |
- git-mcp-server Vendorcyanheads Affected before 2.1.5 Fixed in 2.1.5 Patch available CNA
- @cyanheads/git-mcp-server (npm) Vendor— Affected before 2.1.5 Fixed in 2.1.5 Patch available GHSA-3q26-f695-pp76
Remediation
- Fix · CNA git-mcp-server (cyanheads) Fixed in 2.1.5
- Fix · GHSA-3q26-f695-pp76 @cyanheads/git-mcp-server (npm) Fixed in 2.1.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-53107
- 2026-10-03 Alias added: GHSA-3q26-f695-pp76
References
More cyanheads vulnerabilities
- TI-2026-58751 git-mcp-server 2.15.1 Argument Injection via Git Ref Parameters CVSS 4.0HIGH 8.7
Sources
- CVE-2025-53107 · CVE Program
- CVE-2025-53107 · NVD
- FIRST EPSS
- GHSA-3q26-f695-pp76 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences