ethereum does not check transaction malleability for EIP-2930, EIP-1559 and EIP-7702 transactions
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
ethereum is a common ethereum structs for Rust. Prior to ethereum crate v0.18.0, signature malleability (according to EIP-2) was only checked for "legacy" transactions, but not for EIP-2930, EIP-1559 and EIP-7702 transactions. This is a specification deviation. The signature malleability itself is not a security issue and not as high of a risk if the ethereum crate is used on a single-implementation blockchain. This issue has been patched in version v0.18.0. A workaround for this issue involves manually checking transaction malleability outside of the crate, however upgrading is recommended.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| rust-ethereum | ethereum | before 0.18.0 | 0.18.0 | Patch available | CNA |
| — | ethereum (crates.io) | before 0.18.0 | 0.18.0 | Patch available | GHSA-3w94-vq2x-v5wr |
- ethereum Vendorrust-ethereum Affected before 0.18.0 Fixed in 0.18.0 Patch available CNA
- ethereum (crates.io) Vendor— Affected before 0.18.0 Fixed in 0.18.0 Patch available GHSA-3w94-vq2x-v5wr
Remediation
- Fix · CNA ethereum (rust-ethereum) Fixed in 0.18.0
- Fix · GHSA-3w94-vq2x-v5wr ethereum (crates.io) Fixed in 0.18.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-53359
- 2026-10-03 Alias added: GHSA-3w94-vq2x-v5wr
References
Sources
- CVE-2025-53359 · CVE Program
- CVE-2025-53359 · NVD
- FIRST EPSS
- GHSA-3w94-vq2x-v5wr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences