WordPress Userpro plugin < 5.1.11 - Cross Site Request Forgery (CSRF) vulnerability
Priority LOW 19CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
Cross-Site Request Forgery (CSRF) vulnerability in DeluxeThemes Userpro userpro allows Cross Site Request Forgery.This issue affects Userpro: from n/a through < 5.1.11.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00098 0th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| DeluxeThemes | Userpro | up to 5.1.11 | — | No fix listed | CNA |
- Userpro VendorDeluxeThemes Affected up to 5.1.11 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-53444
- 2026-10-03 Alias added: GHSA-74c3-5r2f-v2xg
More DeluxeThemes vulnerabilities
- TI-2019-10789 cosenary Instagram-PHP-API (aka Instagram PHP API V2), as used in the UserPro plugin… CVSS 3.0MEDIUM 6.1
- TI-2017-12173 The UserPro plugin before 4.9.17.1 for WordPress, when used on a site with the "admin"… CVSS 3.0CRITICAL 9.8
- TI-2023-02290 UserPro <= 5.1.1 - Authentication Bypass to Administrator CVSS 3.1CRITICAL 9.8
- TI-2024-11883 Media Manager for UserPro <= 3.12.0 - Missing Authorization to Unauthenticated Arbitrary Options Update CVSS 3.1CRITICAL 9.8
- TI-2023-02301 UserPro <= 5.1.1 - Insecure Password Reset Mechanism CVSS 3.1CRITICAL 9.8
- TI-2024-23569 WordPress UserPro plugin <= 5.1.8 - Unauthenticated Account Takeover vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-53444 · CVE Program
- CVE-2025-53444 · NVD
- FIRST EPSS
- GHSA-74c3-5r2f-v2xg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences