SecurePoll: Multiple admin actions vulnerable to Cross-Site Request Forgery
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
ArchivePage.php, UnarchivePage.php, and VoterEligibilityPage#executeClear() do not validate request methods or CSRF tokens, allowing attackers to trigger sensitive actions if an admin visits a malicious site. This issue affects Mediawiki - SecurePoll extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | Mediawiki - SecurePoll extension | 1.39.x to before 1.39.13; 1.42.x to before 1.42.7; 1.43.x to before 1.43.2 | 1.39.13, 1.42.7, 1.43.2 | Patch available | CNA |
- Mediawiki - SecurePoll extension VendorWikimedia Foundation Affected 1.39.x to before 1.39.13; 1.42.x to before 1.42.7; 1.43.x to before 1.43.2 Fixed in 1.39.13, 1.42.7, 1.43.2 Patch available CNA
Remediation
- Fix · CNA Mediawiki - SecurePoll extension (Wikimedia Foundation) Fixed in 1.39.13, 1.42.7, 1.43.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Wikimedia Foundation Mediawiki - SecurePoll extension 1.39.13, 1.42.7, 1.43.2
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2025-33429 SecurePoll: Multiple locations vulnerable to Cross-Site Scripting (XSS) via unescaped inputPriority MEDIUM 50
- TI-2025-33430 SecurePoll: Unauthorized access to SetTranslationHandler allows arbitrary text changesPriority LOW 39
Timeline
- 2026-10-02 Threatist record created from CVE-2025-53483
- 2026-10-03 Alias added: GHSA-ggcw-hfmh-53q3
References
More Wikimedia Foundation vulnerabilities
- TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
- TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
- TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
- TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
- TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
- TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
Sources
- CVE-2025-53483 · CVE Program
- CVE-2025-53483 · NVD
- FIRST EPSS
- GHSA-ggcw-hfmh-53q3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences