Read the docs
TI-2025-33434 Aliases CVE-2025-53489GHSA-cp9r-2j44-2x52

XSS in GoogleDocs4MW

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - GoogleDocs4MW Extension allows Cross-Site Scripting (XSS).This issue affects Mediawiki - GoogleDocs4MW Extension: from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0025 16th percentileScored 2026-11-07
Fix Fixed Mediawiki - GoogleDocs4MW Extension (Wikimedia Foundation): 1.42.7, 1.43.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Wikimedia FoundationMediawiki - GoogleDocs4MW Extension1.42.x to before 1.42.7; 1.43.x to before 1.43.21.42.7, 1.43.2Patch availableCNA
  • Mediawiki - GoogleDocs4MW Extension VendorWikimedia Foundation Affected 1.42.x to before 1.42.7; 1.43.x to before 1.43.2 Fixed in 1.42.7, 1.43.2 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jackphoenix:googledocs4mw:-:*:*:*:*:mediawiki:*:*not specified by NVDVulnerableJackphoenix
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*1.42.0 to before 1.42.7; 1.43.0 to before 1.43.2Running onmediawiki
  • cpe:2.3:a:jackphoenix:googledocs4mw:-:*:*:*:*:mediawiki:*:* Versions not specified by NVD Vulnerable ·Jackphoenix
  • cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions 1.42.0 to before 1.42.7; 1.43.0 to before 1.43.2 Running on ·mediawiki

Remediation

  • Fix · CNA Mediawiki - GoogleDocs4MW Extension (Wikimedia Foundation) Fixed in 1.42.7, 1.43.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-53489
  2. 2026-10-03 Alias added: GHSA-cp9r-2j44-2x52

References

  • TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
  • TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
  • TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
  • TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
  • TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
  • TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
See all 255 →

Sources