Read the docs
TI-2025-33439 Aliases CVE-2025-53494GHSA-986p-23cm-hgg6

Stored XSS in TwoColConflict

Priority LOW 34CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - TwoColConflict Extension allows Stored XSS.This issue affects Mediawiki - TwoColConflict Extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00263 18th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Mediawiki - TwoColConflict Extension (Wikimedia Foundation): 1.39.13, 1.42.7, 1.43.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Wikimedia FoundationMediawiki - TwoColConflict Extension1.39.x to before 1.39.13; 1.42.x to before 1.42.7; 1.43.x to before 1.43.21.39.13, 1.42.7, 1.43.2Patch availableCNA
  • Mediawiki - TwoColConflict Extension VendorWikimedia Foundation Affected 1.39.x to before 1.39.13; 1.42.x to before 1.42.7; 1.43.x to before 1.43.2 Fixed in 1.39.13, 1.42.7, 1.43.2 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:wmde-fisch:twocolconflict:*:*:*:*:*:mediawiki:*:*before 2025-05-26VulnerableWmde-fisch
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*1.39.0 to before 1.39.13; 1.42.0 to before 1.42.7; 1.43.0 to before 1.43.2Running onmediawiki
  • cpe:2.3:a:wmde-fisch:twocolconflict:*:*:*:*:*:mediawiki:*:* Versions before 2025-05-26 Vulnerable ·Wmde-fisch
  • cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions 1.39.0 to before 1.39.13; 1.42.0 to before 1.42.7; 1.43.0 to before 1.43.2 Running on ·mediawiki

Remediation

  • Fix · CNA Mediawiki - TwoColConflict Extension (Wikimedia Foundation) Fixed in 1.39.13, 1.42.7, 1.43.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-53494
  2. 2026-10-03 Alias added: GHSA-986p-23cm-hgg6

References

  • TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
  • TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
  • TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
  • TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
  • TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
  • TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
See all 255 →

Sources