docusaurus-plugin-content-gists Exposes GitHub Personal Access Token
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
The Docusaurus gists plugin adds a page to your Docusaurus instance, displaying all public gists of a GitHub user. docusaurus-plugin-content-gists versions prior to 4.0.0 are vulnerable to exposing GitHub Personal Access Tokens in production build artifacts when passed through plugin configuration options. The token, intended for build-time API access only, is inadvertently included in client-side JavaScript bundles, making it accessible to anyone who can view the website's source code. This vulnerability is fixed in 4.0.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| webbertakken | docusaurus-plugin-content-gists | before 4.0.0 | 4.0.0 | Patch available | CNA |
| — | docusaurus-plugin-content-gists (npm) | before 4.0.0 | 4.0.0 | Patch available | GHSA-qf34-qpr4-5pph |
- docusaurus-plugin-content-gists Vendorwebbertakken Affected before 4.0.0 Fixed in 4.0.0 Patch available CNA
- docusaurus-plugin-content-gists (npm) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-qf34-qpr4-5pph
Remediation
- Fix · CNA docusaurus-plugin-content-gists (webbertakken) Fixed in 4.0.0
- Fix · GHSA-qf34-qpr4-5pph docusaurus-plugin-content-gists (npm) Fixed in 4.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-53624
- 2026-10-03 Alias added: GHSA-qf34-qpr4-5pph
References
Sources
- CVE-2025-53624 · CVE Program
- CVE-2025-53624 · NVD
- FIRST EPSS
- GHSA-qf34-qpr4-5pph · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences