Read the docs
TI-2025-33582 Aliases CVE-2025-53658GHSA-j4wf-9gx8-63f8

Cross-site scripting in Jenkins Applitools Eyes Plugin

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Jenkins Applitools Eyes Plugin 1.16.5 and earlier does not escape the Applitools URL on the build page, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00297 22nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:applitools-eyes (Maven): 1.16.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Applitools Eyes Pluginup to 1.16.5—No fix listedCNA
—org.jenkins-ci.plugins:applitools-eyes (Maven)before 1.16.61.16.6Patch availableGHSA-j4wf-9gx8-63f8
  • Jenkins Applitools Eyes Plugin VendorJenkins Affected up to 1.16.5 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:applitools-eyes (Maven) Vendor— Affected before 1.16.6 Fixed in 1.16.6 Patch available GHSA-j4wf-9gx8-63f8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:applitools_eyes:*:*:*:*:*:jenkins:*:*before 1.16.6VulnerableJenkins
  • cpe:2.3:a:jenkins:applitools_eyes:*:*:*:*:*:jenkins:*:* Versions before 1.16.6 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-j4wf-9gx8-63f8 org.jenkins-ci.plugins:applitools-eyes (Maven) Fixed in 1.16.6 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Jenkins Applitools Eyes Plugin — Jenkins Security Advisory 2025-07-09

    3 records Highest priority Priority LOW 3 LOW

    Other records, highest priority first

    • TI-2025-33654 Insufficiently protected credentials in Jenkins Applitools Eyes PluginPriority LOW 30
    • TI-2025-33653 Cleartext storage of sensitive information in Jenkins Applitools Eyes PluginPriority LOW 28

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-53658
  2. 2026-10-03 Alias added: GHSA-j4wf-9gx8-63f8

References

  • TI-2025-33654 Insufficiently protected credentials in Jenkins Applitools Eyes Plugin CVSS 3.1MEDIUM 5.3
  • TI-2025-33653 Cleartext storage of sensitive information in Jenkins Applitools Eyes Plugin CVSS 3.1MEDIUM 6.5

Sources