mcp-package-docs vulnerable to command injection in several tools
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
mcp-package-docs is an MCP (Model Context Protocol) server that provides LLMs with efficient access to package documentation across multiple programming languages and language server protocol (LSP) capabilities. A command injection vulnerability exists in the `mcp-package-docs` MCP Server prior to the fix in commit cb4ad49615275379fd6f2f1cf1ec4731eec56eb9. The vulnerability is caused by the unsanitized use of input parameters within a call to `child_process.exec`, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (`|`, `>`, `&&`, etc.). Commit cb4ad49615275379fd6f2f1cf1ec4731eec56eb9 in version 0.1.27 contains a fix for the issue, but upgrading to 0.1.28 is recommended.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| sammcj | mcp-package-docs | before 0.1.27 | 0.1.27 | Patch available | CNA |
| — | mcp-package-docs (npm) | before 0.1.28 | 0.1.28 | Patch available | GHSA-vf9j-h32g-2764 |
- mcp-package-docs Vendorsammcj Affected before 0.1.27 Fixed in 0.1.27 Patch available CNA
- mcp-package-docs (npm) Vendor— Affected before 0.1.28 Fixed in 0.1.28 Patch available GHSA-vf9j-h32g-2764
Remediation
- Fix · CNA mcp-package-docs (sammcj) Fixed in 0.1.27
- Fix · GHSA-vf9j-h32g-2764 mcp-package-docs (npm) Fixed in 0.1.28 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54073
- 2026-10-03 Alias added: GHSA-vf9j-h32g-2764
References
Advisory 4
Other 7
- https://github.com/sammcj/mcp-package-docs/security/advisories/GHSA-vf9j-h32g-2764
- https://github.com/sammcj/mcp-package-docs/commit/cb4ad49615275379fd6f2f1cf1ec4731eec56eb9
- https://equixly.com/blog/2025/03/29/mcp-server-new-security-nightmare
- https://github.com/sammcj/mcp-package-docs/releases/tag/v0.1.27
- https://github.com/sammcj/mcp-package-docs/releases/tag/v0.1.28
- https://invariantlabs.ai/blog/mcp-github-vulnerability
- https://github.com/sammcj/mcp-package-docs
Sources
- CVE-2025-54073 · CVE Program
- CVE-2025-54073 · NVD
- FIRST EPSS
- GHSA-vf9j-h32g-2764 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences