Cross-site Scripting vulnerability in Secure Access prior to 14.10
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
CVE-2025-54089 is a cross-site scripting vulnerability in versions of secure access prior to 14.10. Attackers with administrative access to the console can interfere with another administrator’s access to the console. The attack complexity is low; there are no attack requirements. Privileges required to execute the attack are high and the victim must actively participate in the attack sequence. There is no impact to confidentiality or availability, there is a low impact to integrity.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Absolute Security | Secure Access | before 14.10 | 14.10 | Patch available | CNA |
- Secure Access VendorAbsolute Security Affected before 14.10 Fixed in 14.10 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:absolute:secure_access:*:*:*:*:*:*:*:* | before 14.10 | Vulnerable | Absolute Security |
- cpe:2.3:a:absolute:secure_access:*:*:*:*:*:*:*:* Versions before 14.10 Vulnerable ·Absolute Security
Remediation
- Fix · CNA Secure Access (Absolute Security) Fixed in 14.10
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54089
- 2026-10-03 Alias added: GHSA-h9v2-pf5m-946v
References
More Absolute Security Secure Access vulnerabilities
- TI-2026-25841 Memory management vulnerability in Secure Access servers CVSS 4.0HIGH 8.7
- TI-2026-39972 Out-of-bounds read in Absolute Security Secure Access CVSS 4.0HIGH 8.7
- TI-2026-29603 Privilge misconfiguration in Secure Access installers CVSS 4.0HIGH 8.5
- TI-2026-25847 Arbitrary read/write vulnerability in Windows clients prior to 14.50 CVSS 4.0HIGH 8.5
- TI-2025-31193 Memory management vulnerability in Absolute Secure Access server versions 9.0 to 13.54 CVSS 4.0HIGH 8.7
- TI-2026-39971 NULL pointer dereference in Absolute Security Secure Access CVSS 4.0MEDIUM 6.9
Sources
- CVE-2025-54089 · CVE Program
- CVE-2025-54089 · NVD
- FIRST EPSS
- GHSA-h9v2-pf5m-946v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences