Cursor's MCP Install Deeplink Does Not Show Arguments in its User-Dialog
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure, Code execution
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-200 and CWE-78.
Summary
Cursor is a code editor built for programming with AI. In versions 1.17 through 1.2, there is a UI information disclosure vulnerability in Cursor's MCP (Model Context Protocol) deeplink handler, allowing attackers to execute 2-click arbitrary system commands through social engineering attacks. When users click malicious `cursor://anysphere.cursor-deeplink/mcp/install` links, the installation dialog does not show the arguments being passed to the command being run. If a user clicks a malicious deeplink, then examines the installation dialog and clicks through, the full command including the arguments will be executed on the machine. This is fixed in version 1.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA cursor (cursor) Fixed in 1.3
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54133
References
More Cursor vulnerabilities
- TI-2026-45043 Cursor for Windows 3.2.16 RCE via Malicious git.exe in Workspace CVSS 4.0HIGH 8.7
- TI-2025-33979 Cursor's Modification of MCP Server Definitions Bypasses Manual Re-approvals CVSS 3.1HIGH 8.8
- TI-2026-37271 Cursor Desktop sandbox escape via symlink and failed path canonicalization CVSS 4.0CRITICAL 9.3
- TI-2026-37270 Cursor Desktop sandbox escape via agent-controlled working directory CVSS 4.0CRITICAL 9.3
- TI-2025-38037 Cursor CLI's Cursor Agent MCP OAuth2 Communication is Vulnerable to Remote Code Execution CVSS 3.1HIGH 8.8
- TI-2025-33978 Cursor Agent is vulnerable to prompt injection via MCP Special Files CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences