SuiteCRM is vulnerable to Cross Site Scripting (XSS) through its email viewer
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. There is a Cross Site Scripting (XSS) vulnerability in the email viewer in versions 7.14.0 through 7.14.6. An external attacker could send a prepared message to the inbox of the SuiteCRM-instance. By simply viewing emails as the logged-in user, the payload can be triggered. With that, an attacker is able to run arbitrary actions as the logged-in user - like extracting data, or if it is an admin executing the payload, takeover the instance. This is fixed in versions 7.14.7.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SuiteCRM | SuiteCRM | 7.14.0 to before 7.14.7 | 7.14.7 | Patch available | CNA |
- SuiteCRM VendorSuiteCRM Affected 7.14.0 to before 7.14.7 Fixed in 7.14.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:salesagility:suitecrm:*:*:*:*:*:*:*:* | 7.14.0 to before 7.14.7; 8.6.0 to before 8.8.1 | Vulnerable | salesagility |
- cpe:2.3:a:salesagility:suitecrm:*:*:*:*:*:*:*:* Versions 7.14.0 to before 7.14.7; 8.6.0 to before 8.8.1 Vulnerable ·salesagility
Remediation
- Fix · CNA SuiteCRM (SuiteCRM) Fixed in 7.14.7
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54784
References
More SuiteCRM vulnerabilities
- TI-2019-15717 SuiteCRM 7.10.7 SQL Injection via record Parameter CVSS 4.0HIGH 7.1
- TI-2019-15716 SuiteCRM 7.10.7 SQL Injection via parentTab Parameter CVSS 4.0HIGH 7.1
- TI-2025-39885 SuiteCRM is Vulnerable to Authenticated Blind SQL Injection via GraphQL CVSS 3.1MEDIUM 6.5
- TI-2025-39883 SuiteCRM is vulnerable to unauthenticated reflected XSS through its Login page CVSS 3.1MEDIUM 6.1
- TI-2026-70691 Missing authorization in SuiteCRM DetailUserRole exposes user ACL data CVSS 4.0MEDIUM 5.3
- TI-2022-26063 SuiteCRM < 7.12.6 SQL Injection via 'export' Functionality CVSS 4.0CRITICAL 9.3
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences