Vision UI's security-kit Contains Cryptographic Weakness
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Vision UI is a collection of enterprise-grade, dependency-free modules for modern web projects. In versions 1.4.0 and below, the getSecureRandomInt function in security-kit versions prior to 3.5.0 (packaged in Vision-ui <= 1.4.0) contains a critical cryptographic weakness. Due to a silent 32-bit integer overflow in its internal masking logic, the function fails to produce a uniform distribution of random numbers when the requested range between min and max is larger than 2³². The root cause is the use of a 32-bit bitwise left-shift operation (<<) to generate a bitmask for the rejection sampling algorithm. This causes the mask to be incorrect for any range requiring 32 or more bits of entropy. This issue is fixed in version 1.5.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| DavidOsipov | Vision-ui | before 1.5.0 | 1.5.0 | Patch available | CNA |
- Vision-ui VendorDavidOsipov Affected before 1.5.0 Fixed in 1.5.0 Patch available CNA
Remediation
- Fix · CNA Vision-ui (DavidOsipov) Fixed in 1.5.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54883
References
More DavidOsipov vulnerabilities
- TI-2025-34618 Vision UI security-kit.js: Potential Uncontrolled Resource Allocation Vulnerability CVSS 4.0HIGH 8.7
- TI-2025-21191 Post-Quantum Secure Feldman's Verifiable Secret Sharing has Timing Side-Channels in Matrix Operations CVSS 4.0MEDIUM 5.8
- TI-2025-21190 Post-Quantum Secure Feldman's Verifiable Secret Sharing has Inadequate Fault Injection… CVSS 4.0MEDIUM 5.4
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences