Read the docs
TI-2025-34885 Aliases CVE-2025-55210

FreePBX API has a Privilege Escalation Error in GraphQL Allowing Authenticated Users to Access Additional Scopes

Priority LOW 13CWE-270Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Active
Attack complexity
High
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

FreePBX is an open-source web-based graphical user interface (GUI) that manages Asterisk. Prior to 17.0.5 and 16.0.17, FreePBX module api (PBX API) is vulnerable to privilege escalation by authenticated users with REST/GraphQL API access. This vulnerability allows an attacker to forge a valid JWT with full access to the REST and GraphQL APIs on a FreePBX that they've already connected to, possibly as a lower privileged user. The JWT is signed using the api-oauth.key private key. An attacker can generate their own token if they possess this key (e.g., by accessing an affected instance), and specify any scopes they wish (e.g., rest, gql), bypassing traditional authorization checks. However, FreePBX enforces that the jti (JWT ID) claim must exist in the database (api_access_tokens table in the asterisk MySQL database) in order for the token to be accepted. Therefore, the attacker must know a jti value that already exists on the target instance. This vulnerability is fixed in 17.0.5 and 16.0.17.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00344 28th percentileScored 2026-11-07
Fix Fixed api (FreePBX): 16.0.17, 17.0.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
FreePBXapi15.0.1alpha1 to before 16.0.17; 17.0.0 to before 17.0.516.0.17, 17.0.5Patch availableCNA
  • api VendorFreePBX Affected 15.0.1alpha1 to before 16.0.17; 17.0.0 to before 17.0.5 Fixed in 16.0.17, 17.0.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sangoma:freepbx:*:*:*:*:*:*:*:*16.0.2 to before 16.0.17; 17.0.1 to before 17.0.5VulnerableSangoma
  • cpe:2.3:a:sangoma:freepbx:*:*:*:*:*:*:*:* Versions 16.0.2 to before 16.0.17; 17.0.1 to before 17.0.5 Vulnerable ·Sangoma

Remediation

  • Fix · CNA api (FreePBX) Fixed in 16.0.17, 17.0.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-55210

References

  • TI-2025-35702 FreePBX Affected by Authentication Bypass Leading to SQL Injection and RCE KEVCVSS 4.0CRITICAL 10.0
  • TI-2025-39763 FreePBX Administration GUI is Vulnerable to Authenticated Command Injection KEVCVSS 4.0HIGH 8.6
  • TI-2024-38391 FreePBX 16 Authenticated Remote Code Execution via API Module CVSS 4.0HIGH 8.7
  • TI-2014-06023 htdocs_ari/includes/login.php in the ARI Framework module/Asterisk Recording Interface… CVSS 2.0HIGH 10.0
  • TI-2025-36981 FreePBX core module vulnerable to reflected cross-site scripting via Asterisk HTTP Status page CVSS 4.0HIGH 8.5
  • TI-2025-38110 FreePBX Endpoint Manager vulnerable to authenticated arbitrary file upload via fwbrand parameter CVSS 4.0HIGH 8.6
See all 55 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences