Storage Performance Development Kit (SPDK) 25.05 is vulnerable to Buffer Overflow in the…
Priority LOW 25CWE-120Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Storage Performance Development Kit (SPDK) 25.05 is vulnerable to Buffer Overflow in the NVMe-oF target component in SPDK - lib/nvmf.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00327 25th percentileScored 2026-11-07
Fix Fixed spdk (PyPI): 25.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | spdk (PyPI) | before 25.9 | 25.9 | Patch available | GHSA-5m5w-w2h2-fqgq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- spdk (PyPI) Vendor— Affected before 25.9 Fixed in 25.9 Patch available GHSA-5m5w-w2h2-fqgq
Remediation
- Fix · GHSA-5m5w-w2h2-fqgq spdk (PyPI) Fixed in 25.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-57275
- 2026-10-03 Alias added: GHSA-5m5w-w2h2-fqgq
References
Sources
- CVE-2025-57275 · CVE Program
- CVE-2025-57275 · NVD
- FIRST EPSS
- GHSA-5m5w-w2h2-fqgq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences