The Node.js package browserstack-local 1.5.8 contains a command injection vulnerability.
Priority LOW 37CWE-94Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-94.
Summary
The Node.js package browserstack-local 1.5.8 contains a command injection vulnerability. This occurs because the logfile variable is not properly sanitized in lib/Local.js.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00799 56th percentileScored 2026-11-07
Fix Partial browserstack-local (npm): 1.5.9Red Hat: 1 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | browserstack-local (npm) | before 1.5.9 | 1.5.9 | Patch available | GHSA-g4w6-c99w-4wh7 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- browserstack-local (npm) Vendor— Affected before 1.5.9 Fixed in 1.5.9 Patch available GHSA-g4w6-c99w-4wh7
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:browserstack:browserstack-local:1.5.8:*:*:*:*:node.js:*:* | 1.5.8 | Vulnerable | browserstack |
- cpe:2.3:a:browserstack:browserstack-local:1.5.8:*:*:*:*:node.js:*:* Versions 1.5.8 Vulnerable ·browserstack
Remediation
- Fix · GHSA-g4w6-c99w-4wh7 browserstack-local (npm) Fixed in 1.5.9 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Fuse 7 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-57283
- 2026-10-03 Alias added: GHSA-g4w6-c99w-4wh7
References
Sources
- CVE-2025-57283 · CVE Program
- CVE-2025-57283 · NVD
- FIRST EPSS
- GHSA-g4w6-c99w-4wh7 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-57283 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences