Dataease server-side request forgery via unfiltered DB2 JDBC ldap parameter
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Dataease is an open source data analytics and visualization platform. In Dataease versions up to 2.10.12, the patch introduced to mitigate DB2 JDBC deserialization remote code execution attacks only blacklisted the rmi parameter. The ldap parameter in the DB2 JDBC connection string was not filtered, allowing attackers to exploit the DB2 JDBC connection string to trigger server-side request forgery (SSRF). In higher versions of Java, ldap deserialization (autoDeserialize) is disabled by default, preventing remote code execution, but SSRF remains exploitable. Versions up to 2.10.12 are affected. The issue is fixed in version 2.10.13. Updating to 2.10.13 or later is recommended. No known workarounds are documented aside from upgrading.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA dataease (dataease) Fixed in 2.10.13
Timeline
- 2026-10-02 Threatist record created from CVE-2025-58045
References
More Dataease vulnerabilities
- TI-2024-38037 An issue in DataEase v1 allows an attacker to execute arbitrary code via the user account and password components. CVSS 3.1CRITICAL 9.8
- TI-2023-12981 SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed CVSS 3.1CRITICAL 9.8
- TI-2022-18688 Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2026-24677 Dataease: Redshift JDBC RCE Bypass CVSS 4.0CRITICAL 9.3
- TI-2026-24674 DataEase SQL Injection Vulnerability CVSS 4.0CRITICAL 9.3
- TI-2024-37398 DataEase has an unauthorized vulnerability CVSS 4.0CRITICAL 9.3
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences