Read the docs
TI-2025-35907 Aliases CVE-2025-58064GHSA-x9gp-vjh6-3wv6

CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package

Priority LOW 12CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Passive
Attack complexity
Low
Attack requirements
Present
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00417 36th percentileScored 2026-11-07
Fix Fixed ckeditor5 (ckeditor): 46.0.3, 45.2.2ckeditor5 (npm): 46.0.3, 45.2.2+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ckeditorckeditor546.0.0 to before 46.0.3; 44.2.0 to before 45.2.246.0.3, 45.2.2Patch availableCNA
—ckeditor5 (npm)46.0.0 to before 46.0.346.0.3Patch availableGHSA-x9gp-vjh6-3wv6
—@ckeditor/ckeditor5-clipboard (npm)44.2.0 to before 45.2.245.2.2Patch availableGHSA-x9gp-vjh6-3wv6
—ckeditor5 (npm)44.2.0 to before 45.2.245.2.2Patch availableGHSA-x9gp-vjh6-3wv6
—@ckeditor/ckeditor5-clipboard (npm)46.0.0 to before 46.0.346.0.3Patch availableGHSA-x9gp-vjh6-3wv6
  • ckeditor5 Vendorckeditor Affected 46.0.0 to before 46.0.3; 44.2.0 to before 45.2.2 Fixed in 46.0.3, 45.2.2 Patch available CNA
  • ckeditor5 (npm) Vendor— Affected 46.0.0 to before 46.0.3 Fixed in 46.0.3 Patch available GHSA-x9gp-vjh6-3wv6
  • @ckeditor/ckeditor5-clipboard (npm) Vendor— Affected 44.2.0 to before 45.2.2 Fixed in 45.2.2 Patch available GHSA-x9gp-vjh6-3wv6
  • ckeditor5 (npm) Vendor— Affected 44.2.0 to before 45.2.2 Fixed in 45.2.2 Patch available GHSA-x9gp-vjh6-3wv6
  • @ckeditor/ckeditor5-clipboard (npm) Vendor— Affected 46.0.0 to before 46.0.3 Fixed in 46.0.3 Patch available GHSA-x9gp-vjh6-3wv6

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:ckeditor:ckeditor5:*:*:*:*:*:*:*:*——ckeditor
  • cpe:2.3:a:ckeditor:ckeditor5:*:*:*:*:*:*:*:* Versions — — ·ckeditor

Remediation

  • Fix · CNA ckeditor5 (ckeditor) Fixed in 46.0.3, 45.2.2
  • Fix · GHSA-x9gp-vjh6-3wv6 ckeditor5 (npm) Fixed in 46.0.3 Advisory →
  • Fix · GHSA-x9gp-vjh6-3wv6 @ckeditor/ckeditor5-clipboard (npm) Fixed in 45.2.2 Advisory →
  • Fix · GHSA-x9gp-vjh6-3wv6 ckeditor5 (npm) Fixed in 45.2.2 Advisory →
  • Fix · GHSA-x9gp-vjh6-3wv6 @ckeditor/ckeditor5-clipboard (npm) Fixed in 46.0.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-58064
  2. 2026-10-03 Alias added: GHSA-x9gp-vjh6-3wv6

References

  • TI-2023-15111 A unrestricted file upload vulnerability was discovered in the ‘Browse and upload images’… CVSS 3.1CRITICAL 9.8
  • TI-2025-37971 A reflected cross-site scripting (XSS) vulnerability in CKeditor v46.1.0 & Angular… CVSS 3.1MEDIUM 5.4
  • TI-2021-18004 HTML comments vulnerability allowing to execute JavaScript code CVSS 3.1HIGH 8.2
  • TI-2026-81521 Cross-site scripting in CKEditor 5 engine package CVSS 3.1HIGH 8.1
  • TI-2022-08543 Regular expression Denial of Service in dialog plugin CVSS 3.1HIGH 7.5
  • TI-2021-18003 Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML CVSS 3.1HIGH 8.2
See all 38 →

Sources